summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-01-05 08:37:00 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-01-05 08:42:24 +0000
commit3adc7e343f41581f05e3d52ded688bc231548658 (patch)
tree3c9a0eb487b7fe9714cdefa3dfc65e98fbd3a71e /sys-devel/gdb/gdb-10.1.ebuild
parentwww-apps/webdavcgi: Removing legacy 1.1.1 version. (diff)
downloadgentoo-3adc7e343f41581f05e3d52ded688bc231548658.tar.gz
gentoo-3adc7e343f41581f05e3d52ded688bc231548658.tar.bz2
gentoo-3adc7e343f41581f05e3d52ded688bc231548658.zip
sys-devel/gdb: make CET optional (and disabled by default)
Reported-by: Volker Ernst Bug: https://bugs.gentoo.org/760926 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/gdb/gdb-10.1.ebuild')
-rw-r--r--sys-devel/gdb/gdb-10.1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sys-devel/gdb/gdb-10.1.ebuild b/sys-devel/gdb/gdb-10.1.ebuild
index 0d958a65b3c2..dc5210dbe4eb 100644
--- a/sys-devel/gdb/gdb-10.1.ebuild
+++ b/sys-devel/gdb/gdb-10.1.ebuild
@@ -46,7 +46,7 @@ SLOT="0"
if [[ ${PV} != 9999* ]] ; then
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
-IUSE="+client lzma multitarget nls +python +server source-highlight test vanilla xml xxhash"
+IUSE="cet +client lzma multitarget nls +python +server source-highlight test vanilla xml xxhash"
REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
|| ( client server )
@@ -131,8 +131,13 @@ src_configure() {
--disable-{binutils,etc,gas,gold,gprof,ld}
# avoid automagic dependency on (currently prefix) systems
- # systems with debuginfod library, bgu #754753
+ # systems with debuginfod library, bug #754753
--without-debuginfod
+
+ # Allow user to opt into CET for host libraries.
+ # Ideally we would like automagic-or-disabled here.
+ # But the check does not quite work on i686: bug #760926.
+ $(use_enable cet)
)
local sysroot="${EPREFIX}/usr/${CTARGET}"
is_cross && myconf+=(