summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2020-01-20 13:48:41 +0300
committerSergei Trofimovich <slyfox@gentoo.org>2020-01-20 19:38:16 +0000
commitabc12b4d6fc5a276cdf82cf92066a27a9b5020a6 (patch)
tree61ff889414802d0db308e454233e8f1eccab7112 /sys-devel/gdb/gdb-9999.ebuild
parentdev-util/dwarves: Apply elfutils changes from dwarves-16-r1 also to live ebuild (diff)
downloadgentoo-abc12b4d6fc5a276cdf82cf92066a27a9b5020a6.tar.gz
gentoo-abc12b4d6fc5a276cdf82cf92066a27a9b5020a6.tar.bz2
gentoo-abc12b4d6fc5a276cdf82cf92066a27a9b5020a6.zip
sys-devel/gdb: call python_optimize, bug #705680
Closes: https://bugs.gentoo.org/705680 Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/gdb/gdb-9999.ebuild')
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 9fc57491538d..6188f7eb4f51 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -244,6 +244,10 @@ src_install() {
if [[ ${CHOST} == *-freebsd* ]]; then
rm "${ED}"/usr/bin/gcore || die
fi
+
+ if use python; then
+ python_optimize "${ED}"/usr/share/gdb/python/gdb
+ fi
}
pkg_postinst() {