summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-11-24 12:58:43 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-11-24 12:58:43 +0000
commite6e69875cadca6985633a18eaba92c052a5142b9 (patch)
tree43d73ff77b22144bbb5fa972d4fb0c072fbc756f /sys-devel/gdb
parentmedia-libs/gegl: stable 0.3.26 for ppc, bug #641322 (diff)
downloadgentoo-e6e69875cadca6985633a18eaba92c052a5142b9.tar.gz
gentoo-e6e69875cadca6985633a18eaba92c052a5142b9.tar.bz2
gentoo-e6e69875cadca6985633a18eaba92c052a5142b9.zip
sys-devel/gdb: fix sparc build, bug #671726
Reported-by: Rolf Eike Beer Bug: https://bugs.gentoo.org/671726 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/gdb')
-rw-r--r--sys-devel/gdb/files/gdb-8.2-sparc-fix-syntax.patch10
-rw-r--r--sys-devel/gdb/gdb-8.2-r1.ebuild6
2 files changed, 15 insertions, 1 deletions
diff --git a/sys-devel/gdb/files/gdb-8.2-sparc-fix-syntax.patch b/sys-devel/gdb/files/gdb-8.2-sparc-fix-syntax.patch
new file mode 100644
index 000000000000..5ed32c04fd79
--- /dev/null
+++ b/sys-devel/gdb/files/gdb-8.2-sparc-fix-syntax.patch
@@ -0,0 +1,10 @@
+Fix invalid c++: https://bugs.gentoo.org/671726
+--- a/gdb/sparc-linux-nat.c
++++ b/gdb/sparc-linux-nat.c
+@@ -36,5 +36,5 @@ public:
+ { sparc_fetch_inferior_registers (regcache, regnum); }
+
+- void store_registers (struct regcache *regcache, int regnum) override;
++ void store_registers (struct regcache *regcache, int regnum) override
+ { sparc_store_inferior_registers (regcache, regnum); }
+ };
diff --git a/sys-devel/gdb/gdb-8.2-r1.ebuild b/sys-devel/gdb/gdb-8.2-r1.ebuild
index d7f7e1ef262d..254563307729 100644
--- a/sys-devel/gdb/gdb-8.2-r1.ebuild
+++ b/sys-devel/gdb/gdb-8.2-r1.ebuild
@@ -90,6 +90,11 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}-${MY_PV}
+PATCHES=(
+ "${FILESDIR}"/${P}-tinfow.patch
+ "${FILESDIR}"/${P}-sparc-fix-syntax.patch
+)
+
pkg_setup() {
use python && python-single-r1_pkg_setup
}
@@ -101,7 +106,6 @@ src_prepare() {
EPATCH_EXCLUDE+=" 01_all_ia64-TRAP_HWBKPT.patch"
EPATCH_EXCLUDE+=" 02_all_solaris-no-uuidsys.patch"
! use vanilla && [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
- eapply "${FILESDIR}"/${P}-tinfow.patch
default