summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-devel/heirloom-devtools/heirloom-devtools-070527-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-devel/heirloom-devtools/heirloom-devtools-070527-r1.ebuild')
-rw-r--r--sys-devel/heirloom-devtools/heirloom-devtools-070527-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sys-devel/heirloom-devtools/heirloom-devtools-070527-r1.ebuild b/sys-devel/heirloom-devtools/heirloom-devtools-070527-r1.ebuild
new file mode 100644
index 000000000000..7dd30a9eaae2
--- /dev/null
+++ b/sys-devel/heirloom-devtools/heirloom-devtools-070527-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Original UNIX development tools"
+HOMEPAGE="http://heirloom.sourceforge.net/devtools.html"
+SRC_URI="http://downloads.sourceforge.net/project/heirloom/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="BSD BSD-4 CDDL"
+SLOT="0"
+KEYWORDS="~amd64 ~x64-solaris"
+IUSE=""
+
+DEPEND="app-shells/heirloom-sh"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+
+ sed -i \
+ -e 's:^\(SHELL =\) \(.*\):\1 /bin/jsh:' \
+ -e 's:^\(POSIX_SHELL =\) \(.*\):\1 /bin/sh:' \
+ -e "s:^\(PREFIX=\)\(.*\):\1${EPREFIX}\2:" \
+ -e "s:^\(SUSBIN=\)\(.*\):\1${EPREFIX}\2:" \
+ -e "s:^\(LDFLAGS=\):\1${LDFLAGS}:" \
+ -e "s:^\(CFLAGS=\)\(.*\):\1${CFLAGS}:" \
+ -e 's:^\(STRIP=\)\(.*\):\1true:' \
+ -e "s:^\(CXX = \)\(.*\):\1$(tc-getCXX):" \
+ -e "s:^\(INSTALL=\)\(.*\):\1$(which install):" \
+ ./mk.config
+
+ echo "CC=$(tc-getCC)" >> "./mk.config"
+
+ epatch "${FILESDIR}/${P}-solaris.patch"
+ epatch "${FILESDIR}/${P}-64-bit.patch"
+
+ epatch_user
+
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake ROOT="${D}" install
+}
+
+pkg_postinst() {
+ elog "You may want to add /usr/5bin or /usr/ucb to \$PATH"
+ elog "to enable using the apps of heirloom toolchest by default."
+ elog "Man pages are installed in /usr/share/man/5man/"
+ elog "You may need to set \$MANPATH to access them."
+}