summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-04-04 13:50:19 +0200
committerPacho Ramos <pacho@gentoo.org>2017-04-04 14:05:07 +0200
commit6bdcdc31ed91e397ad8d8cca4ffac2b4b4619e3a (patch)
treeaf49737b31ad6047e65755b47acc17fcf2a71eba /sys-devel/heirloom-devtools/heirloom-devtools-999999.ebuild
parentapp-i18n/zinnia: Fix gcc6 support, bug #594048 by milan hodoscek and Peter Le... (diff)
downloadgentoo-6bdcdc31ed91e397ad8d8cca4ffac2b4b4619e3a.tar.gz
gentoo-6bdcdc31ed91e397ad8d8cca4ffac2b4b4619e3a.tar.bz2
gentoo-6bdcdc31ed91e397ad8d8cca4ffac2b4b4619e3a.zip
sys-devel/heirloom-devtools: Fix gcc6 support, bug #594090 by Peter Levine, also adapt to eapi6 and not show elog messages always.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sys-devel/heirloom-devtools/heirloom-devtools-999999.ebuild')
-rw-r--r--sys-devel/heirloom-devtools/heirloom-devtools-999999.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/sys-devel/heirloom-devtools/heirloom-devtools-999999.ebuild b/sys-devel/heirloom-devtools/heirloom-devtools-999999.ebuild
index 1299aaabeffd..1d97661d245b 100644
--- a/sys-devel/heirloom-devtools/heirloom-devtools-999999.ebuild
+++ b/sys-devel/heirloom-devtools/heirloom-devtools-999999.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-
-inherit cvs flag-o-matic toolchain-funcs
+EAPI=6
+inherit cvs flag-o-matic readme.gentoo-r1 toolchain-funcs
ECVS_AUTH="pserver"
ECVS_USER="anonymous"
@@ -24,10 +23,17 @@ IUSE=""
DEPEND="app-shells/heirloom-sh"
RDEPEND="${DEPEND}"
+DOC_CONTENTS="
+ You may want to add /usr/5bin or /usr/ucb to \$PATH
+ to enable using the apps of heirloom toolchest by default.
+ Man pages are installed in /usr/share/man/5man/
+ You may need to set \$MANPATH to access them.
+"
+
S="${WORKDIR}/${PN}"
src_prepare() {
-
+ default
sed -i \
-e 's:^\(SHELL =\) \(.*\):\1 /bin/jsh:' \
-e 's:^\(POSIX_SHELL =\) \(.*\):\1 /bin/sh:' \
@@ -41,7 +47,6 @@ src_prepare() {
./mk.config
echo "CC=$(tc-getCC)" >> "./mk.config"
-
}
src_compile() {
@@ -50,11 +55,9 @@ src_compile() {
src_install() {
emake ROOT="${D}" install
+ readme.gentoo_create_doc
}
pkg_postinst() {
- elog "You may want to add /usr/5bin or /usr/ucb to \$PATH"
- elog "to enable using the apps of heirloom toolchest by default."
- elog "Man pages are installed in /usr/share/man/5man/"
- elog "You may need to set \$MANPATH to access them."
+ readme.gentoo_print_elog
}