summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-05-09 12:47:58 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-05-09 12:53:19 +0100
commit656b64e075041bd5e44a930ff9239e5e43f48f61 (patch)
treecf70aea1f95cd2506aa33dacd539b917936ffa19 /sys-devel/kgcc64/kgcc64-10.2.0.ebuild
parentsys-devel/kgcc64: drop old (diff)
downloadgentoo-656b64e075041bd5e44a930ff9239e5e43f48f61.tar.gz
gentoo-656b64e075041bd5e44a930ff9239e5e43f48f61.tar.bz2
gentoo-656b64e075041bd5e44a930ff9239e5e43f48f61.zip
sys-devel/kgcc64: drop old
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/kgcc64/kgcc64-10.2.0.ebuild')
-rw-r--r--sys-devel/kgcc64/kgcc64-10.2.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/sys-devel/kgcc64/kgcc64-10.2.0.ebuild b/sys-devel/kgcc64/kgcc64-10.2.0.ebuild
deleted file mode 100644
index c8abbd9325b8..000000000000
--- a/sys-devel/kgcc64/kgcc64-10.2.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-case ${CHOST} in
- hppa*) CTARGET=hppa64-${CHOST#*-};;
- mips*) CTARGET=${CHOST/mips/mips64};;
- powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
- s390*) CTARGET=${CHOST/s390/s390x};;
- sparc*) CTARGET=${CHOST/sparc/sparc64};;
- i?86*) CTARGET=x86_64-${CHOST#*-};;
-esac
-export CTARGET
-TOOLCHAIN_ALLOWED_LANGS="c"
-GCC_TARGET_NO_MULTILIB=true
-
-PATCH_VER="1"
-inherit toolchain
-
-DESCRIPTION="64bit kernel compiler"
-
-# Works on hppa and mips; all other archs, refer to bug #228115
-KEYWORDS="~hppa"
-
-# unlike every other target, hppa has not unified the 32/64 bit
-# ports in binutils yet
-DEPEND="hppa? ( sys-devel/binutils-hppa64 )"
-
-pkg_postinst() {
- toolchain_pkg_postinst
-
- cd "${ROOT}"/usr/bin
- local x
- for x in gcc cpp ; do
- cat <<-EOF >${CTARGET%%-*}-linux-${x}
- #!/bin/sh
- exec ${CTARGET}-${x} "\$@"
- EOF
- chmod a+rx ${CTARGET%%-*}-linux-${x}
- done
-}