summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-12-09 14:52:27 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-12-09 14:53:40 +0100
commite5719bec93136e71cc64b6357d24f1199df33a8e (patch)
tree806275e34a349b027aaa3c35ca43ae89953c2063 /sys-devel/libtool
parentsys-devel/libtool: Stable for amd64 and x86 (bug #601098). (diff)
downloadgentoo-e5719bec93136e71cc64b6357d24f1199df33a8e.tar.gz
gentoo-e5719bec93136e71cc64b6357d24f1199df33a8e.tar.bz2
gentoo-e5719bec93136e71cc64b6357d24f1199df33a8e.zip
sys-devel/libtool: Removed old.
Package-Manager: portage-2.3.3
Diffstat (limited to 'sys-devel/libtool')
-rw-r--r--sys-devel/libtool/Manifest3
-rw-r--r--sys-devel/libtool/files/1.5.20/libtool-1.5.20-use-linux-version-in-fbsd.patch38
-rw-r--r--sys-devel/libtool/libtool-2.4.2-r1.ebuild96
-rw-r--r--sys-devel/libtool/libtool-2.4.4.ebuild77
-rw-r--r--sys-devel/libtool/libtool-2.4.5.ebuild77
-rw-r--r--sys-devel/libtool/libtool-2.4.6-r1.ebuild84
6 files changed, 0 insertions, 375 deletions
diff --git a/sys-devel/libtool/Manifest b/sys-devel/libtool/Manifest
index ba9189f74af..5c4e7a050f6 100644
--- a/sys-devel/libtool/Manifest
+++ b/sys-devel/libtool/Manifest
@@ -1,4 +1 @@
-DIST libtool-2.4.2.tar.xz 868760 SHA256 1d7b6862c1ed162e327f083a6f78f40eae29218f0db8c38393d61dab764c4407 SHA512 34f2d4a32beb4d85cfefd9c2c4ff33b0117e9e89c6599c303a7b850c43be5ed090b2f530388b8c8154e8f3f693abd2079180dca9afc948feb800b2e009bed169 WHIRLPOOL 300697c30b6cf693463338ee3bfe10b9ccce2c496b319862182124828caf7b667a7e9cf21f287572ec1fed8abe529a14d171da2983369522faf3eed5513a1af5
-DIST libtool-2.4.4.tar.xz 957476 SHA256 a8295b5853bf82a46635c944031e84970f2aa79c19df7a0c28f3ec8e11c07f6c SHA512 1ff24aa88962e0aae82e1fff41df7863f925627a506c6a663a79afa23729272aa4e5816889dd4697d5286d42483bcee2cc7352514768f1bd28ea546476074a84 WHIRLPOOL def0381a3608b52f8f5e9b83d297643d48d3e695117199b10b4ae3d6f5b11f3d3a36c4b6572b7659061c3fee77e46da4f5e3cfffa594063fed0fe382869c3539
-DIST libtool-2.4.5.tar.xz 971620 SHA256 84aac136513b009278896ffa255e4d685bcdb0cb0e5363be36adad64c986177e SHA512 67ceb387e33fbf0ffe6df422cd26939e305a365bb22674ce064ed7f7d6602054682515b014e290c70587b7f9b6f85f00fac31d6f000b4b022daaa2b343c17327 WHIRLPOOL 4a5171a8f23d50b78eb70bbd2ff9497fe2a970933392c65c41ab44600838cdc744e4e9ddfef37ac009cf5784de8c7b1ef061f8156919b7417e78529978afe7ed
DIST libtool-2.4.6.tar.xz 973080 SHA256 7c87a8c2c8c0fc9cd5019e402bed4292462d00a718a7cd5f11218153bf28b26f SHA512 a6eef35f3cbccf2c9e2667f44a476ebc80ab888725eb768e91a3a6c33b8c931afc46eb23efaee76c8696d3e4eed74ab1c71157bcb924f38ee912c8a90a6521a4 WHIRLPOOL f6e1ea25cc8dd853f0de53c045bcd1166cfede9cb0e890079c2c05e6cbdb5e705e137f83ba32f7e16691b9c9108e9cfb2d14ed030cea07b6eacbe3f1ae18a73b
diff --git a/sys-devel/libtool/files/1.5.20/libtool-1.5.20-use-linux-version-in-fbsd.patch b/sys-devel/libtool/files/1.5.20/libtool-1.5.20-use-linux-version-in-fbsd.patch
deleted file mode 100644
index cc9d8b82d61..00000000000
--- a/sys-devel/libtool/files/1.5.20/libtool-1.5.20-use-linux-version-in-fbsd.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-Force linux-style versioning when generating shared libraries on
-Gentoo/FreeBSD hosts only.
-
-Patch by Diego Pettenò
-
-http://bugs.gentoo.org/109105
-
---- libtool-1.5.20/libtool.m4
-+++ libtool-1.5.20/libtool.m4
-@@ -1375,7 +1375,14 @@ freebsd* | dragonfly*)
- *) objformat=elf ;;
- esac
- fi
-- version_type=freebsd-$objformat
-+ # Handle Gentoo/FreeBSD as it was Linux
-+ case $host_vendor in
-+ gentoo)
-+ version_type=linux ;;
-+ *)
-+ version_type=freebsd-$objformat ;;
-+ esac
-+
- case $version_type in
- freebsd-elf*)
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
-@@ -1386,6 +1392,12 @@ freebsd* | dragonfly*)
- library_names_spec='${libname}${release}${shared_ext}$versuffix $libname${shared_ext}$versuffix'
- need_version=yes
- ;;
-+ linux)
-+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
-+ soname_spec='${libname}${release}${shared_ext}$major'
-+ need_lib_prefix=no
-+ need_version=no
-+ ;;
- esac
- shlibpath_var=LD_LIBRARY_PATH
- case $host_os in
diff --git a/sys-devel/libtool/libtool-2.4.2-r1.ebuild b/sys-devel/libtool/libtool-2.4.2-r1.ebuild
deleted file mode 100644
index 7aa4d883370..00000000000
--- a/sys-devel/libtool/libtool-2.4.2-r1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-LIBTOOLIZE="true" #225559
-WANT_LIBTOOL="none"
-inherit eutils autotools multilib unpacker multilib-minimal
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.savannah.gnu.org/${PN}.git
- http://git.savannah.gnu.org/r/${PN}.git"
- inherit git-2
-else
- SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-fi
-
-DESCRIPTION="A shared library tool for developers"
-HOMEPAGE="https://www.gnu.org/software/libtool/"
-
-LICENSE="GPL-2"
-SLOT="2"
-IUSE="static-libs test vanilla"
-
-RDEPEND="sys-devel/gnuconfig
- !<sys-devel/autoconf-2.62:2.5
- !<sys-devel/automake-1.11.1:1.11
- !=sys-devel/libtool-2*:1.5
- abi_x86_32? (
- !<=app-emulation/emul-linux-x86-baselibs-20140406-r2
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
- )"
-DEPEND="${RDEPEND}
- test? ( !<sys-devel/binutils-2.20 )
- app-arch/xz-utils"
-[[ ${PV} == "9999" ]] && DEPEND+=" sys-apps/help2man"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git-2_src_unpack
- cd "${S}"
- ./bootstrap || die
- else
- unpacker_src_unpack
- fi
-}
-
-src_prepare() {
- use vanilla && return 0
-
- cd libltdl/m4
- epatch "${FILESDIR}"/1.5.20/${PN}-1.5.20-use-linux-version-in-fbsd.patch #109105
- cd ..
- AT_NOELIBTOOLIZE=yes eautoreconf
- cd ..
- AT_NOELIBTOOLIZE=yes eautoreconf
- epunt_cxx
-}
-
-multilib_src_configure() {
- # the libtool script uses bash code in it and at configure time, tries
- # to find a bash shell. if /bin/sh is bash, it uses that. this can
- # cause problems for people who switch /bin/sh on the fly to other
- # shells, so just force libtool to use /bin/bash all the time.
- export CONFIG_SHELL=/bin/bash
- ECONF_SOURCE="${S}" \
- econf $(use_enable static-libs static)
-}
-
-multilib_src_install_all() {
- dodoc AUTHORS ChangeLog* NEWS README THANKS TODO doc/PLATFORMS
-
- # While the libltdl.la file is not used directly, the m4 ltdl logic
- # keys off of its existence when searching for ltdl support. #293921
- #use static-libs || find "${D}" -name libltdl.la -delete
-
- # Building libtool with --disable-static will cause the installed
- # helper to not build static objects by default. This is undesirable
- # for crappy packages that utilize the system libtool, so undo that.
- sed -i -e '1,/^build_old_libs=/{/^build_old_libs=/{s:=.*:=yes:}}' "${D}"/usr/bin/libtool || die
-
- local x
- for x in $(find "${D}" -name config.guess -o -name config.sub) ; do
- ln -sf /usr/share/gnuconfig/${x##*/} "${x}" || die
- done
-}
-
-pkg_preinst() {
- preserve_old_lib /usr/$(get_libdir)/libltdl.so.3
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /usr/$(get_libdir)/libltdl.so.3
-}
diff --git a/sys-devel/libtool/libtool-2.4.4.ebuild b/sys-devel/libtool/libtool-2.4.4.ebuild
deleted file mode 100644
index 71a9b47a26f..00000000000
--- a/sys-devel/libtool/libtool-2.4.4.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-LIBTOOLIZE="true" #225559
-WANT_LIBTOOL="none"
-inherit eutils autotools multilib unpacker
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.savannah.gnu.org/${PN}.git
- http://git.savannah.gnu.org/r/${PN}.git"
- inherit git-2
-else
- SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-fi
-
-DESCRIPTION="A shared library tool for developers"
-HOMEPAGE="https://www.gnu.org/software/libtool/"
-
-LICENSE="GPL-2"
-SLOT="2"
-IUSE="vanilla"
-
-# Pull in libltdl directly until we convert packages to the new dep.
-RDEPEND="sys-devel/gnuconfig
- >=sys-devel/autoconf-2.69
- >=sys-devel/automake-1.13
- dev-libs/libltdl:0"
-DEPEND="${RDEPEND}
- app-arch/xz-utils"
-[[ ${PV} == "9999" ]] && DEPEND+=" sys-apps/help2man"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git-2_src_unpack
- cd "${S}"
- ./bootstrap || die
- else
- unpacker_src_unpack
- fi
-}
-
-src_prepare() {
- use vanilla && return 0
-
- epatch "${FILESDIR}"/${PN}-2.4.3-use-linux-version-in-fbsd.patch #109105
- pushd libltdl >/dev/null
- AT_NOELIBTOOLIZE=yes eautoreconf
- popd >/dev/null
- AT_NOELIBTOOLIZE=yes eautoreconf
- epunt_cxx
-}
-
-src_configure() {
- # the libtool script uses bash code in it and at configure time, tries
- # to find a bash shell. if /bin/sh is bash, it uses that. this can
- # cause problems for people who switch /bin/sh on the fly to other
- # shells, so just force libtool to use /bin/bash all the time.
- export CONFIG_SHELL=/bin/bash
- ECONF_SOURCE=${S} econf --disable-ltdl-install
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- default
-
- local x
- while read -d $'\0' -r x ; do
- ln -sf "${EPREFIX}"/usr/share/gnuconfig/${x##*/} "${x}" || die
- done < <(find "${ED}" '(' -name config.guess -o -name config.sub ')' -print0)
-}
diff --git a/sys-devel/libtool/libtool-2.4.5.ebuild b/sys-devel/libtool/libtool-2.4.5.ebuild
deleted file mode 100644
index 7b0936cf9f2..00000000000
--- a/sys-devel/libtool/libtool-2.4.5.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-LIBTOOLIZE="true" #225559
-WANT_LIBTOOL="none"
-inherit eutils autotools multilib unpacker
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.savannah.gnu.org/${PN}.git
- http://git.savannah.gnu.org/r/${PN}.git"
- inherit git-2
-else
- SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-fi
-
-DESCRIPTION="A shared library tool for developers"
-HOMEPAGE="https://www.gnu.org/software/libtool/"
-
-LICENSE="GPL-2"
-SLOT="2"
-IUSE="vanilla"
-
-# Pull in libltdl directly until we convert packages to the new dep.
-RDEPEND="sys-devel/gnuconfig
- >=sys-devel/autoconf-2.69
- >=sys-devel/automake-1.13
- dev-libs/libltdl:0"
-DEPEND="${RDEPEND}
- app-arch/xz-utils"
-[[ ${PV} == "9999" ]] && DEPEND+=" sys-apps/help2man"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git-2_src_unpack
- cd "${S}"
- ./bootstrap || die
- else
- unpacker_src_unpack
- fi
-}
-
-src_prepare() {
- use vanilla && return 0
-
- epatch "${FILESDIR}"/${PN}-2.4.3-use-linux-version-in-fbsd.patch #109105
- pushd libltdl >/dev/null
- AT_NOELIBTOOLIZE=yes eautoreconf
- popd >/dev/null
- AT_NOELIBTOOLIZE=yes eautoreconf
- epunt_cxx
-}
-
-src_configure() {
- # the libtool script uses bash code in it and at configure time, tries
- # to find a bash shell. if /bin/sh is bash, it uses that. this can
- # cause problems for people who switch /bin/sh on the fly to other
- # shells, so just force libtool to use /bin/bash all the time.
- export CONFIG_SHELL=/bin/bash
- ECONF_SOURCE=${S} econf --disable-ltdl-install
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- default
-
- local x
- while read -d $'\0' -r x ; do
- ln -sf "${EPREFIX}"/usr/share/gnuconfig/${x##*/} "${x}" || die
- done < <(find "${ED}" '(' -name config.guess -o -name config.sub ')' -print0)
-}
diff --git a/sys-devel/libtool/libtool-2.4.6-r1.ebuild b/sys-devel/libtool/libtool-2.4.6-r1.ebuild
deleted file mode 100644
index 677db335de6..00000000000
--- a/sys-devel/libtool/libtool-2.4.6-r1.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-LIBTOOLIZE="true" #225559
-WANT_LIBTOOL="none"
-inherit eutils autotools multilib unpacker
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.savannah.gnu.org/${PN}.git
- http://git.savannah.gnu.org/r/${PN}.git"
- inherit git-2
-else
- SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-fi
-
-DESCRIPTION="A shared library tool for developers"
-HOMEPAGE="https://www.gnu.org/software/libtool/"
-
-LICENSE="GPL-2"
-SLOT="2"
-IUSE="vanilla"
-
-# Pull in libltdl directly until we convert packages to the new dep.
-RDEPEND="sys-devel/gnuconfig
- >=sys-devel/autoconf-2.69
- >=sys-devel/automake-1.13
- dev-libs/libltdl:0"
-DEPEND="${RDEPEND}
- app-arch/xz-utils"
-[[ ${PV} == "9999" ]] && DEPEND+=" sys-apps/help2man"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git-2_src_unpack
- cd "${S}"
- ./bootstrap || die
- else
- unpacker_src_unpack
- fi
-}
-
-src_prepare() {
- use vanilla && return 0
-
- epatch "${FILESDIR}"/${PN}-2.4.3-use-linux-version-in-fbsd.patch #109105
- epatch "${FILESDIR}"/${P}-fuse-ld.patch
- pushd libltdl >/dev/null
- AT_NOELIBTOOLIZE=yes eautoreconf
- popd >/dev/null
- AT_NOELIBTOOLIZE=yes eautoreconf
- epunt_cxx
-
- # Make sure timestamps don't trigger a rebuild of man pages. #556512
- if [[ ${PV} != "9999" ]] ; then
- touch doc/*.1
- export HELP2MAN=false
- fi
-}
-
-src_configure() {
- # the libtool script uses bash code in it and at configure time, tries
- # to find a bash shell. if /bin/sh is bash, it uses that. this can
- # cause problems for people who switch /bin/sh on the fly to other
- # shells, so just force libtool to use /bin/bash all the time.
- export CONFIG_SHELL=/bin/bash
- ECONF_SOURCE=${S} econf --disable-ltdl-install
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- default
-
- local x
- while read -d $'\0' -r x ; do
- ln -sf "${EPREFIX}"/usr/share/gnuconfig/${x##*/} "${x}" || die
- done < <(find "${ED}" '(' -name config.guess -o -name config.sub ')' -print0)
-}