summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-19 10:11:34 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-19 10:11:34 +0100
commit297368e40e976832446ce8f4e1cd06ce91413414 (patch)
treee52d6023a1cd0d98fdff0d3db0036ceb8bd8e001 /sys-devel/llvm-common/llvm-common-11.0.1_rc2.ebuild
parentpackage.mask: Last rite sys-libs/netbsd-csu (diff)
downloadgentoo-297368e40e976832446ce8f4e1cd06ce91413414.tar.gz
gentoo-297368e40e976832446ce8f4e1cd06ce91413414.tar.bz2
gentoo-297368e40e976832446ce8f4e1cd06ce91413414.zip
sys-devel/llvm-common: Bump to 11.0.1-rc2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-11.0.1_rc2.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-11.0.1_rc2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-11.0.1_rc2.ebuild b/sys-devel/llvm-common/llvm-common-11.0.1_rc2.ebuild
new file mode 100644
index 000000000000..4804d9640098
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-11.0.1_rc2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}