summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-30 13:16:29 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-30 20:13:42 +0200
commit9520616aee7743543b003f114a98c7eb6d195922 (patch)
tree46560d18b5dbb47d3c88ba65ad0d77982e3ece42 /sys-devel/llvm-common/llvm-common-14.0.0.9999.ebuild
parentllvm.eclass: Allow slot 14 (diff)
downloadgentoo-9520616aee7743543b003f114a98c7eb6d195922.tar.gz
gentoo-9520616aee7743543b003f114a98c7eb6d195922.tar.bz2
gentoo-9520616aee7743543b003f114a98c7eb6d195922.zip
sys-devel/llvm-common: Bump live to 14*
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-14.0.0.9999.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-14.0.0.9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-14.0.0.9999.ebuild b/sys-devel/llvm-common/llvm-common-14.0.0.9999.ebuild
new file mode 100644
index 000000000000..53511a0a20e3
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-14.0.0.9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}