summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-11-22 21:05:56 +0100
committerMichał Górny <mgorny@gentoo.org>2015-11-22 21:11:44 +0100
commit22a7695920dd985cbb8bf2e429723804e3fdce73 (patch)
tree609881cb95960e24125d0d615651c9c9295b36e7 /sys-devel/llvm/files/cmake
parentdev-lisp/clozurecl: fix bug with the ~e format (diff)
downloadgentoo-22a7695920dd985cbb8bf2e429723804e3fdce73.tar.gz
gentoo-22a7695920dd985cbb8bf2e429723804e3fdce73.tar.bz2
gentoo-22a7695920dd985cbb8bf2e429723804e3fdce73.zip
sys-devel/llvm: Update the patch and ebuild partially scan-* changes
Upstream has added installation rules for scan-build and scan-view, and make them FHS-aware. This is mostly neat, except that scan-view expects Python modules in /usr/share. The patch and ebuild is partially updated to accomodate this. It will require at least cleaning up /usr/share still.
Diffstat (limited to 'sys-devel/llvm/files/cmake')
-rw-r--r--sys-devel/llvm/files/cmake/clang-0001-Install-clang-runtime-into-usr-lib-without-suffix-3.8.patch4
1 files changed, 1 insertions, 3 deletions
diff --git a/sys-devel/llvm/files/cmake/clang-0001-Install-clang-runtime-into-usr-lib-without-suffix-3.8.patch b/sys-devel/llvm/files/cmake/clang-0001-Install-clang-runtime-into-usr-lib-without-suffix-3.8.patch
index cf2ca5947016..931eb56e5a96 100644
--- a/sys-devel/llvm/files/cmake/clang-0001-Install-clang-runtime-into-usr-lib-without-suffix-3.8.patch
+++ b/sys-devel/llvm/files/cmake/clang-0001-Install-clang-runtime-into-usr-lib-without-suffix-3.8.patch
@@ -29,9 +29,7 @@ diff --git a/lib/Headers/CMakeLists.txt b/lib/Headers/CMakeLists.txt
index 7de5fbe..49f439b 100644
--- a/tools/clang/lib/Headers/CMakeLists.txt
+++ b/tools/clang/lib/Headers/CMakeLists.txt
-@@ -98,4 +98,4 @@ set_target_properties(clang-headers PROPERTIES FOLDER "Misc")
- install(
- FILES ${files} ${CMAKE_CURRENT_BINARY_DIR}/arm_neon.h
+@@ -100,4 +100,4 @@ set_target_properties(clang-headers PROPERTIES FOLDER "Misc")
PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ
- DESTINATION lib${LLVM_LIBDIR_SUFFIX}/clang/${CLANG_VERSION}/include)
+ DESTINATION lib/clang/${CLANG_VERSION}/include)