summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuta Satoh <nigoro.dev@gmail.com>2016-06-18 14:44:10 +0900
committerPatrice Clement <monsieurp@gentoo.org>2016-06-23 15:26:09 +0000
commit12280fd5851883571f9e0f0ec44432d2bd17e187 (patch)
tree581409fba4941e5d1d670f1aab2ce5a24e596103 /sys-devel/llvm/files
parentapp-admin/grubconfig: fix SRC_URI (diff)
downloadgentoo-12280fd5851883571f9e0f0ec44432d2bd17e187.tar.gz
gentoo-12280fd5851883571f9e0f0ec44432d2bd17e187.tar.bz2
gentoo-12280fd5851883571f9e0f0ec44432d2bd17e187.zip
sys-devel/llvm: Fix build fails on Gentoo/FreeBSD.
Gentoo-Bug: https://bugs.gentoo.org/578064 Closes: https://github.com/gentoo/gentoo/pull/1693 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'sys-devel/llvm/files')
-rw-r--r--sys-devel/llvm/files/clang-3.8-compiler-rt-fbsd.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/sys-devel/llvm/files/clang-3.8-compiler-rt-fbsd.patch b/sys-devel/llvm/files/clang-3.8-compiler-rt-fbsd.patch
new file mode 100644
index 000000000000..297620bc775a
--- /dev/null
+++ b/sys-devel/llvm/files/clang-3.8-compiler-rt-fbsd.patch
@@ -0,0 +1,20 @@
+https://llvm.org/bugs/show_bug.cgi?id=26651
+https://github.com/llvm-mirror/compiler-rt/commit/6606c7b50cbb4ec7eab4ecbebbbaaa049734bbd3
+
+diff --git a/projects/compiler-rt/lib/tsan/CMakeLists.txt b/projects/compiler-rt/lib/tsan/CMakeLists.txt
+index c185cfa..a151c6c 100644
+--- a/projects/compiler-rt/lib/tsan/CMakeLists.txt
++++ b/projects/compiler-rt/lib/tsan/CMakeLists.txt
+@@ -192,7 +192,11 @@ endif()
+ add_dependencies(compiler-rt tsan)
+
+ # Make sure that non-platform-specific files don't include any system headers.
+-if(COMPILER_RT_HAS_SYSROOT_FLAG)
++# FreeBSD does not install a number of Clang-provided headers for the compiler
++# in the base system due to incompatibilities between FreeBSD's and Clang's
++# versions. As a workaround do not use --sysroot=. on FreeBSD until this is
++# addressed.
++if(COMPILER_RT_HAS_SYSROOT_FLAG AND NOT CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
+ file(GLOB _tsan_generic_sources rtl/tsan*)
+ file(GLOB _tsan_platform_sources rtl/tsan*posix* rtl/tsan*mac*
+ rtl/tsan*linux*)