summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-22 13:12:59 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-22 13:21:37 +0200
commita473a7a0611264f648e8a6a7518c4616c6c153fc (patch)
treea0a25dddd167e4afc5bf591f9ba696a74fac17db /sys-devel/llvm/files
parentllvm.org.eclass: Support Gentoo patchsets (diff)
downloadgentoo-a473a7a0611264f648e8a6a7518c4616c6c153fc.tar.gz
gentoo-a473a7a0611264f648e8a6a7518c4616c6c153fc.tar.bz2
gentoo-a473a7a0611264f648e8a6a7518c4616c6c153fc.zip
sys-devel/llvm: Switch to patchsets
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/llvm/files')
-rw-r--r--sys-devel/llvm/files/10.0.1/0001-llvm-Avoid-linking-llvm-cfi-verify-to-duplicate-libs.patch48
-rw-r--r--sys-devel/llvm/files/10.0.1/0002-llvm-Disable-linking-llvm-exegesis-to-dylib.patch29
-rw-r--r--sys-devel/llvm/files/11.0.0/0001-backport-D88371-guard-find_library-tensorflow_c_api.patch55
-rw-r--r--sys-devel/llvm/files/9999/0007-llvm-config-Clean-up-exported-values-update-for-shar.patch34
4 files changed, 0 insertions, 166 deletions
diff --git a/sys-devel/llvm/files/10.0.1/0001-llvm-Avoid-linking-llvm-cfi-verify-to-duplicate-libs.patch b/sys-devel/llvm/files/10.0.1/0001-llvm-Avoid-linking-llvm-cfi-verify-to-duplicate-libs.patch
deleted file mode 100644
index 445cb6de2c32..000000000000
--- a/sys-devel/llvm/files/10.0.1/0001-llvm-Avoid-linking-llvm-cfi-verify-to-duplicate-libs.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From bc3be897be6994da7f52ba1b5735aa81150084a4 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Tue, 16 Jun 2020 12:16:52 +0200
-Subject: [PATCH 1/4] [llvm] Avoid linking llvm-cfi-verify to duplicate libs
-
-Fix the CMake rules for LLVMCFIVerify library not to pull duplicate
-LLVM .a libraries when linking to the dylib. This prevents problems
-due to duplicate symbols and apparently fixes mingw32.
-
-This is an alternative approach to D44650 that just forces .a libraries
-instead. However, there doesn't seem to be any reason to do that.
----
- llvm/tools/llvm-cfi-verify/lib/CMakeLists.txt | 20 +++++++++++--------
- 1 file changed, 12 insertions(+), 8 deletions(-)
-
-diff --git a/llvm/tools/llvm-cfi-verify/lib/CMakeLists.txt b/llvm/tools/llvm-cfi-verify/lib/CMakeLists.txt
-index 82ca42e624a..41d55ed9321 100644
---- a/llvm/tools/llvm-cfi-verify/lib/CMakeLists.txt
-+++ b/llvm/tools/llvm-cfi-verify/lib/CMakeLists.txt
-@@ -7,13 +7,17 @@ add_library(LLVMCFIVerify
- )
-
- llvm_update_compile_flags(LLVMCFIVerify)
--llvm_map_components_to_libnames(libs
-- DebugInfoDWARF
-- MC
-- MCParser
-- Object
-- Support
-- Symbolize
-- )
-+if (LLVM_LINK_LLVM_DYLIB)
-+ set(libs LLVM)
-+else()
-+ llvm_map_components_to_libnames(libs
-+ DebugInfoDWARF
-+ MC
-+ MCParser
-+ Object
-+ Support
-+ Symbolize
-+ )
-+endif()
- target_link_libraries(LLVMCFIVerify ${libs})
- set_target_properties(LLVMCFIVerify PROPERTIES FOLDER "Libraries")
---
-2.27.0
-
diff --git a/sys-devel/llvm/files/10.0.1/0002-llvm-Disable-linking-llvm-exegesis-to-dylib.patch b/sys-devel/llvm/files/10.0.1/0002-llvm-Disable-linking-llvm-exegesis-to-dylib.patch
deleted file mode 100644
index 24786905c4d9..000000000000
--- a/sys-devel/llvm/files/10.0.1/0002-llvm-Disable-linking-llvm-exegesis-to-dylib.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 07b6fdcde1ed64043244965b97788a2b12af4d6d Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Tue, 16 Jun 2020 12:31:36 +0200
-Subject: [PATCH 2/4] [llvm] Disable linking llvm-exegesis to dylib
-
-Force linking llvm-exegesis to static LLVM libraries instead of dylib
-to prevent duplicate symbols due to linking both. Ideally, we'd want
-to link to the dylib only here but the target sub-libraries use hidden
-symbols from LLVM target libraries and therefore linking the dylib
-fails.
----
- llvm/tools/llvm-exegesis/CMakeLists.txt | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/llvm/tools/llvm-exegesis/CMakeLists.txt b/llvm/tools/llvm-exegesis/CMakeLists.txt
-index a59e1b74024..0575f2a06bb 100644
---- a/llvm/tools/llvm-exegesis/CMakeLists.txt
-+++ b/llvm/tools/llvm-exegesis/CMakeLists.txt
-@@ -5,6 +5,7 @@ set(LLVM_LINK_COMPONENTS
- )
-
- add_llvm_tool(llvm-exegesis
-+ DISABLE_LLVM_LINK_LLVM_DYLIB
- llvm-exegesis.cpp
- )
-
---
-2.27.0
-
diff --git a/sys-devel/llvm/files/11.0.0/0001-backport-D88371-guard-find_library-tensorflow_c_api.patch b/sys-devel/llvm/files/11.0.0/0001-backport-D88371-guard-find_library-tensorflow_c_api.patch
deleted file mode 100644
index 73959afb2677..000000000000
--- a/sys-devel/llvm/files/11.0.0/0001-backport-D88371-guard-find_library-tensorflow_c_api.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From 8dcb88f7705fb3927938dd9bd103efcabafcefb0 Mon Sep 17 00:00:00 2001
-From: Georgy Yakovlev <gyakovlev@gentoo.org>
-Date: Tue, 27 Oct 2020 18:20:56 -0700
-Subject: [PATCH] backport D88371, guard `find_library(tensorflow_c_api ...)`
-
-Differential Revision: https://reviews.llvm.org/D88371
-Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
----
- llvm/CMakeLists.txt | 15 +++++++--------
- 1 file changed, 7 insertions(+), 8 deletions(-)
-
-diff --git a/llvm/CMakeLists.txt b/llvm/CMakeLists.txt
-index 1f137f0..4112def 100644
---- a/llvm/CMakeLists.txt
-+++ b/llvm/CMakeLists.txt
-@@ -832,6 +832,11 @@ configure_file(
- ${LLVM_INCLUDE_DIR}/llvm/Config/Targets.def
- )
-
-+# They are not referenced. See set_output_directory().
-+set( CMAKE_RUNTIME_OUTPUT_DIRECTORY ${LLVM_BINARY_DIR}/bin )
-+set( CMAKE_LIBRARY_OUTPUT_DIRECTORY ${LLVM_BINARY_DIR}/lib${LLVM_LIBDIR_SUFFIX} )
-+set( CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${LLVM_BINARY_DIR}/lib${LLVM_LIBDIR_SUFFIX} )
-+
- # For up-to-date instructions for installing the Tensorflow dependency, refer to
- # the bot setup script: https://github.com/google/ml-compiler-opt/blob/master/buildbot/buildbot_init.sh
- # In this case, the latest C API library is available for download from
-@@ -840,9 +845,9 @@ configure_file(
- # LLVM_HAVE_TF_API, through llvm-config.h, so that a user of the LLVM library may
- # also leverage the dependency.
- set(TENSORFLOW_C_LIB_PATH "" CACHE PATH "Path to TensorFlow C library install")
--find_library(tensorflow_c_api tensorflow PATHS ${TENSORFLOW_C_LIB_PATH}/lib)
-
--if (tensorflow_c_api)
-+if (TENSORFLOW_C_LIB_PATH)
-+ find_library(tensorflow_c_api tensorflow PATHS ${TENSORFLOW_C_LIB_PATH}/lib NO_DEFAULT_PATH REQUIRED)
- set(LLVM_HAVE_TF_API "ON" CACHE BOOL "Full Tensorflow API available")
- include_directories(${TENSORFLOW_C_LIB_PATH}/include)
- endif()
-@@ -877,12 +882,6 @@ add_custom_target(srpm
- COMMAND rpmbuild -bs --define '_topdir ${LLVM_SRPM_DIR}' ${LLVM_SRPM_BINARY_SPECFILE})
- set_target_properties(srpm PROPERTIES FOLDER "Misc")
-
--
--# They are not referenced. See set_output_directory().
--set( CMAKE_RUNTIME_OUTPUT_DIRECTORY ${LLVM_BINARY_DIR}/bin )
--set( CMAKE_LIBRARY_OUTPUT_DIRECTORY ${LLVM_BINARY_DIR}/lib${LLVM_LIBDIR_SUFFIX} )
--set( CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${LLVM_BINARY_DIR}/lib${LLVM_LIBDIR_SUFFIX} )
--
- if(APPLE AND DARWIN_LTO_LIBRARY)
- set(CMAKE_EXE_LINKER_FLAGS
- "${CMAKE_EXE_LINKER_FLAGS} -Wl,-lto_library -Wl,${DARWIN_LTO_LIBRARY}")
---
-2.26.2
-
diff --git a/sys-devel/llvm/files/9999/0007-llvm-config-Clean-up-exported-values-update-for-shar.patch b/sys-devel/llvm/files/9999/0007-llvm-config-Clean-up-exported-values-update-for-shar.patch
deleted file mode 100644
index cf52314ce755..000000000000
--- a/sys-devel/llvm/files/9999/0007-llvm-config-Clean-up-exported-values-update-for-shar.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 628b899be14a6bab4b32dbd53aabd447dcc16cb7 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sat, 20 Aug 2016 23:47:41 +0200
-Subject: [PATCH] llvm-config: Clean up exported values, update for shared
- linking
-
-Gentoo-specific fixup for llvm-config, including:
-- making --src-root return invalid path (/dev/null).
-
-Thanks to Steven Newbury for the initial patch.
-
-Bug: https://bugs.gentoo.org/565358
-Bug: https://bugs.gentoo.org/501684
-
-diff --git a/tools/llvm-config/llvm-config.cpp b/tools/llvm-config/llvm-config.cpp
-index d780094861c..c61c72ff48c 100644
---- a/tools/llvm-config/llvm-config.cpp
-+++ b/tools/llvm-config/llvm-config.cpp
-@@ -549,7 +550,11 @@ int main(int argc, char **argv) {
- } else if (Arg == "--obj-root") {
- OS << ActivePrefix << '\n';
- } else if (Arg == "--src-root") {
-- OS << LLVM_SRC_ROOT << '\n';
-+ if (IsInDevelopmentTree) {
-+ OS << LLVM_SRC_ROOT << '\n';
-+ } else {
-+ OS << "/dev/null\n";
-+ }
- } else if (Arg == "--ignore-libllvm") {
- LinkDyLib = false;
- LinkMode = BuiltSharedLibs ? LinkModeShared : LinkModeAuto;
---
-2.11.0
-