summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuta Satoh <nigoro.dev@gmail.com>2016-02-08 20:48:04 +0900
committerYuta Satoh <nigoro.dev@gmail.com>2016-02-08 20:48:04 +0900
commit7e9333237199d0e062d94e4ca026cb41b9dcb28f (patch)
tree3fa9d4a45e509cc0051c8cd1633e23a67af26417 /sys-devel/llvm/llvm-3.8.0_rc1.ebuild
parentnet-misc/whatportis: Version Bump (diff)
downloadgentoo-7e9333237199d0e062d94e4ca026cb41b9dcb28f.tar.gz
gentoo-7e9333237199d0e062d94e4ca026cb41b9dcb28f.tar.bz2
gentoo-7e9333237199d0e062d94e4ca026cb41b9dcb28f.zip
sys-devel/llvm: Re add the code for Gentoo/FreeBSD.
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=417171
Diffstat (limited to 'sys-devel/llvm/llvm-3.8.0_rc1.ebuild')
-rw-r--r--sys-devel/llvm/llvm-3.8.0_rc1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-devel/llvm/llvm-3.8.0_rc1.ebuild b/sys-devel/llvm/llvm-3.8.0_rc1.ebuild
index 613a5faf2159..8c598b7fec2a 100644
--- a/sys-devel/llvm/llvm-3.8.0_rc1.ebuild
+++ b/sys-devel/llvm/llvm-3.8.0_rc1.ebuild
@@ -23,7 +23,8 @@ LICENSE="UoI-NCSA"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="clang debug doc gold libedit +libffi lldb multitarget ncurses ocaml
- python +static-analyzer test xml video_cards_radeon kernel_Darwin"
+ python +static-analyzer test xml video_cards_radeon
+ kernel_Darwin kernel_FreeBSD"
COMMON_DEPEND="
sys-libs/zlib:0=
@@ -416,6 +417,9 @@ src_install() {
fi
multilib-minimal_src_install
+
+ # Remove unnecessary headers on FreeBSD, bug #417171
+ use kernel_FreeBSD && use clang && rm "${ED}"usr/lib/clang/${PV}/include/{std,float,iso,limits,tgmath,varargs}*.h
}
multilib_src_install() {