summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-03-28 23:22:50 +0200
committerMichał Górny <mgorny@gentoo.org>2016-03-28 23:31:31 +0200
commit234e8985ace9589ec251d7020648b9c10e4c2d25 (patch)
treecd4a2cad9d8f64b332295378f64ca794f66fac5d /sys-devel/llvm/llvm-9999.ebuild
parentsys-devel/llvm: Update llvm-config & restore shared libs in 3.8, #578392 (diff)
downloadgentoo-234e8985ace9589ec251d7020648b9c10e4c2d25.tar.gz
gentoo-234e8985ace9589ec251d7020648b9c10e4c2d25.tar.bz2
gentoo-234e8985ace9589ec251d7020648b9c10e4c2d25.zip
sys-devel/llvm: Update patches for the live ebuild
Diffstat (limited to 'sys-devel/llvm/llvm-9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 14c5da5d4dec..80eef1b40fe7 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -165,6 +165,10 @@ src_prepare() {
# https://bugs.gentoo.org/show_bug.cgi?id=565358
eapply "${FILESDIR}"/llvm-3.9-llvm-config.patch
+ # Restore SOVERSIONs for shared libraries
+ # https://bugs.gentoo.org/show_bug.cgi?id=578392
+ eapply "${FILESDIR}"/llvm-3.8-soversion.patch
+
# disable use of SDK on OSX, bug #568758
sed -i -e 's/xcrun/false/' utils/lit/lit/util.py || die
@@ -223,7 +227,7 @@ multilib_src_configure() {
local mycmakeargs=(
-DLLVM_LIBDIR_SUFFIX=${libdir#lib}
- -DLLVM_LINK_LLVM_DYLIB=ON
+ -DBUILD_SHARED_LIBS=ON
-DLLVM_ENABLE_TIMESTAMPS=OFF
-DLLVM_TARGETS_TO_BUILD="${targets}"
-DLLVM_BUILD_TESTS=$(usex test)