summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-11-16 17:53:29 +0100
committerMichał Górny <mgorny@gentoo.org>2017-11-16 22:52:07 +0100
commitbffe6a1dd3106ea8c2c1a1a0527f3f650c303341 (patch)
tree922d54792c97c8617c5581bec5f621bdc2ba0a8c /sys-devel/llvm/llvm-9999.ebuild
parentsys-libs/libomp: Call cmake-utils_src_prepare (diff)
downloadgentoo-bffe6a1dd3106ea8c2c1a1a0527f3f650c303341.tar.gz
gentoo-bffe6a1dd3106ea8c2c1a1a0527f3f650c303341.tar.bz2
gentoo-bffe6a1dd3106ea8c2c1a1a0527f3f650c303341.zip
sys-devel/llvm: Stop enforcing external lit for tests
Modify the ebuild to no longer enforce externally installed dev-python/lit for tests, effectively causing the build system to use the bundled copy of lit (along with llvm-lit). While using the external package is more canonical, its disadvantages outweight the gain. Most notably, lit is not slotted in Gentoo and the behavior of lit frequently changes subtly which caused us to require a major version match between LLVM and lit. As a result, attempting to build multiple slots of LLVM with tests enabled cause package collisions. Building both LLVM and lit simultaneously causes a circular dependency. Since lit comes from the same package as LLVM itself and LLVM requires explicit python-any-r1 use anyway, using the bundled copy has no added cost. It reduces the risk of breakage resulting from skipping llvm-lit wrapper and solves the forementioned problems caused by depending on dev-python/lit. The external package is still useful for projects that do not require LLVM sources.
Diffstat (limited to 'sys-devel/llvm/llvm-9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild7
1 files changed, 0 insertions, 7 deletions
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 64f66a7d6c0a..af9daf563fa7 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -57,7 +57,6 @@ DEPEND="${RDEPEND}
doc? ( dev-python/sphinx )
gold? ( sys-libs/binutils-libs )
libffi? ( virtual/pkgconfig )
- test? ( $(python_gen_any_dep "~dev-python/lit-${PV}[\${PYTHON_USEDEP}]") )
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
# There are no file collisions between these versions but having :0
@@ -73,11 +72,6 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
-python_check_deps() {
- ! use test \
- || has_version "dev-python/lit[${PYTHON_USEDEP}]"
-}
-
src_prepare() {
# Fix llvm-config for shared linking and sane flags
# https://bugs.gentoo.org/show_bug.cgi?id=565358
@@ -139,7 +133,6 @@ multilib_src_configure() {
# fi
use test && mycmakeargs+=(
- -DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="-vv"
)