summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-06 08:47:25 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-06 14:47:54 +0200
commitc738aff7a8a27f1c867aef80e1ba392a7a3ee496 (patch)
tree0d6d91fd70d35e4324687a05aef92cb070225765 /sys-devel/llvm
parentsys-devel/llvm: Include MANPATH in env.d file (diff)
downloadgentoo-c738aff7a8a27f1c867aef80e1ba392a7a3ee496.tar.gz
gentoo-c738aff7a8a27f1c867aef80e1ba392a7a3ee496.tar.bz2
gentoo-c738aff7a8a27f1c867aef80e1ba392a7a3ee496.zip
sys-devel/llvm: Fix compressing manpages
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/llvm-4.0.0-r1.ebuild2
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/sys-devel/llvm/llvm-4.0.0-r1.ebuild b/sys-devel/llvm/llvm-4.0.0-r1.ebuild
index 1384df1a1191..c9745dcdf6c7 100644
--- a/sys-devel/llvm/llvm-4.0.0-r1.ebuild
+++ b/sys-devel/llvm/llvm-4.0.0-r1.ebuild
@@ -262,4 +262,6 @@ multilib_src_install_all() {
LDPATH="$( IFS=:; echo "${LLVM_LDPATHS[*]}" )"
_EOF_
doenvd "${T}/10llvm-${revord}"
+
+ docompress "/usr/lib/llvm/${SLOT}/share/man"
}
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 16413680bdfe..44153d7806ec 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -262,4 +262,6 @@ multilib_src_install_all() {
LDPATH="$( IFS=:; echo "${LLVM_LDPATHS[*]}" )"
_EOF_
doenvd "${T}/10llvm-${revord}"
+
+ docompress "/usr/lib/llvm/${SLOT}/share/man"
}