summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-07-03 09:29:46 +0200
committerMichał Górny <mgorny@gentoo.org>2016-07-03 10:19:07 +0200
commitd2563074dd89ab616032b610baed2367b1a5759f (patch)
tree6fef8a728d3e5ede115aad6477d167d08927ab19 /sys-devel/llvm
parentnet-libs/libbitcoinconsensus-0.12*: Add dependency on libsecp256k1 (diff)
downloadgentoo-d2563074dd89ab616032b610baed2367b1a5759f.tar.gz
gentoo-d2563074dd89ab616032b610baed2367b1a5759f.tar.bz2
gentoo-d2563074dd89ab616032b610baed2367b1a5759f.zip
sys-devel/llvm: Use tc-is-gcc from toolchain-funcs
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/llvm-3.8.0-r3.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-devel/llvm/llvm-3.8.0-r3.ebuild b/sys-devel/llvm/llvm-3.8.0-r3.ebuild
index 0b38f2e58fac..31be20b9c065 100644
--- a/sys-devel/llvm/llvm-3.8.0-r3.ebuild
+++ b/sys-devel/llvm/llvm-3.8.0-r3.ebuild
@@ -173,7 +173,7 @@ src_prepare() {
sed -i -e 's/xcrun/false/' utils/lit/lit/util.py || die
# Workaround, can be compiled with gcc on Gentoo/FreeBSD, bug #578064
- use kernel_FreeBSD && [[ $(tc-getCC) == *gcc* ]] && append-cppflags "-D_GLIBCXX_USE_C99"
+ use kernel_FreeBSD && tc-is-gcc && append-cppflags "-D_GLIBCXX_USE_C99"
if use clang; then
# Automatically select active system GCC's libraries, bugs #406163 and #417913