summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2021-03-23 13:26:23 -0400
committerLars Wendler <polynomial-c@gentoo.org>2021-03-26 18:58:28 +0100
commit132dcde9f1a1cd1692b91fa5eabaadc8d03a3340 (patch)
tree0f820b6356d2a049d90aa4e5659f99b6c270bddc /sys-devel/m4/m4-1.4.18-r2.ebuild
parenteclass/common-lisp-3: Fix asd suffix substitution (diff)
downloadgentoo-132dcde9f1a1cd1692b91fa5eabaadc8d03a3340.tar.gz
gentoo-132dcde9f1a1cd1692b91fa5eabaadc8d03a3340.tar.bz2
gentoo-132dcde9f1a1cd1692b91fa5eabaadc8d03a3340.zip
sys-devel/m4: EAPI 7
Closes: https://bugs.gentoo.org/777897 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-devel/m4/m4-1.4.18-r2.ebuild')
-rw-r--r--sys-devel/m4/m4-1.4.18-r2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-devel/m4/m4-1.4.18-r2.ebuild b/sys-devel/m4/m4-1.4.18-r2.ebuild
new file mode 100644
index 000000000000..e8f9585638d5
--- /dev/null
+++ b/sys-devel/m4/m4-1.4.18-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="GNU macro processor"
+HOMEPAGE="https://www.gnu.org/software/m4/m4.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples"
+
+# remember: cannot dep on autoconf since it needs us
+BDEPEND="app-arch/xz-utils"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-darwin17-printf-n.patch
+ "${FILESDIR}"/${P}-glibc228.patch #663924
+)
+
+src_configure() {
+ local -a myeconfargs=(
+ --enable-changeword
+
+ # Disable automagic dependency over libsigsegv; see bug #278026
+ ac_cv_libsigsegv=no
+ )
+
+ [[ ${USERLAND} != GNU ]] && myeconfargs+=( --program-prefix=g )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ [[ -d /none ]] && die "m4 tests will fail with /none/" #244396
+ emake check
+}
+
+src_install() {
+ default
+ # autoconf-2.60 for instance, first checks gm4, then m4. If we don't have
+ # gm4, it might find gm4 from outside the prefix on for instance Darwin
+ use prefix && dosym m4 /usr/bin/gm4
+ if use examples ; then
+ dodoc -r examples
+ rm -f "${ED}"/usr/share/doc/${PF}/examples/Makefile*
+ fi
+}