summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2020-03-12 07:53:27 +0100
committerMichael Haubenwallner <haubi@gentoo.org>2020-03-12 07:54:41 +0100
commit17a34c16162c4109d35ed91efe95853344af624a (patch)
treefe508498b2094c95ff0c87bb44dbe90261703e38 /sys-devel/parity/parity-2.0.1.ebuild
parentxfce-extra/xfce4-whiskermenu-plugin: Bump to 2.4.3 (diff)
downloadgentoo-17a34c16162c4109d35ed91efe95853344af624a.tar.gz
gentoo-17a34c16162c4109d35ed91efe95853344af624a.tar.bz2
gentoo-17a34c16162c4109d35ed91efe95853344af624a.zip
sys-devel/parity: EAPI 7, revbump, old
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Michael Haubenwallner <haubi@gentoo.org>
Diffstat (limited to 'sys-devel/parity/parity-2.0.1.ebuild')
-rw-r--r--sys-devel/parity/parity-2.0.1.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/sys-devel/parity/parity-2.0.1.ebuild b/sys-devel/parity/parity-2.0.1.ebuild
new file mode 100644
index 000000000000..7f41d7bf06e6
--- /dev/null
+++ b/sys-devel/parity/parity-2.0.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == 9999 ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git@github.com:haubi/parity.git https://github.com/haubi/parity.git"
+ BDEPEND="dev-util/confix"
+else
+ SRC_URI="https://github.com/mduft/${PN}/releases/download/${PV}/${P}.tar.bz2"
+ KEYWORDS="~x64-cygwin"
+fi
+DESCRIPTION="A POSIX to native Win32 Cross-Compiler Tool (requires Visual Studio)"
+HOMEPAGE="https://github.com/mduft/parity"
+
+parity-vcarchs() { echo x64=x86_64 x86=i686 ; }
+parity-vcvers-legacy() { echo 8_0 9_0 ; }
+parity-vcvers-current() { echo 10_0 11_0 12_0 14_0 15 16 ; }
+parity-vcvers() {
+ parity-vcvers-legacy
+ parity-vcvers-current
+}
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="$(
+ for a in $(parity-vcarchs); do echo "+vc${a%=*}"; done
+ for v in $(parity-vcvers-legacy); do echo "vc${v}"; done
+ for v in $(parity-vcvers-current); do echo "+vc${v}"; done
+)"
+
+if [[ ${PV} == 9999 ]]; then
+ src_prepare() {
+ default
+ confix --output || die
+ eautoreconf
+ }
+fi
+
+parity-enabled-vcarchs() {
+ local enabled= a
+ for a in $(parity-vcarchs) ; do
+ if use vc${a%=*} ; then
+ enabled+=",${a#*=}"
+ fi
+ done
+ echo ${enabled#,}
+}
+
+parity-enabled-vcvers() {
+ local enabled= v
+ for v in $(parity-vcvers) ; do
+ if use vc${v} ; then
+ enabled+=",${v/_/.}"
+ fi
+ done
+ echo ${enabled#,}
+}
+
+src_configure() {
+ local myconf=(
+ --enable-msvc-archs="$(parity-enabled-vcarchs)"
+ --enable-msvc-versions="$(parity-enabled-vcvers)"
+ --disable-default-msvc-version
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ if [[ -n ${ROOT} ]] ; then
+ einfo "To enable all available MSVC versions, on the target machine please run:"
+ einfo " '${EPREFIX}/usr/bin/parity-setup' --enable-all"
+ else
+ "${EPREFIX}"/usr/bin/parity-setup --enable-all
+ fi
+}