summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-devel/sparse/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-devel/sparse/files')
-rw-r--r--sys-devel/sparse/files/sparse-0.4.3-gentoo.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-devel/sparse/files/sparse-0.4.3-gentoo.patch b/sys-devel/sparse/files/sparse-0.4.3-gentoo.patch
new file mode 100644
index 000000000000..6f46687d78b3
--- /dev/null
+++ b/sys-devel/sparse/files/sparse-0.4.3-gentoo.patch
@@ -0,0 +1,49 @@
+diff --git a/Makefile b/Makefile
+index 74905df..1f2b2b6 100644
+--- a/Makefile
++++ b/Makefile
+@@ -4,7 +4,7 @@ OS = linux
+
+
+ CC = gcc
+-CFLAGS = -O2 -finline-functions -fno-strict-aliasing -g
++CFLAGS ?= -O2 -finline-functions -fno-strict-aliasing -g
+ CFLAGS += -Wall -Wwrite-strings
+ LDFLAGS += -g
+ AR = ar
+@@ -21,7 +21,8 @@ HAVE_GCC_DEP:=$(shell touch .gcc-test.c && \
+ echo 'yes'; rm -f .gcc-test.d .gcc-test.o .gcc-test.c)
+ HAVE_GTK2:=$(shell pkg-config --exists gtk+-2.0 2>/dev/null && echo 'yes')
+
+-CFLAGS += -DGCC_BASE=\"$(shell $(CC) --print-file-name=)\"
++GCC_BASE = $(shell $(CC) --print-file-name=)
++CFLAGS += -DGCC_BASE=\"$(GCC_BASE)\"
+
+ ifeq ($(HAVE_GCC_DEP),yes)
+ CFLAGS += -Wp,-MD,$(@D)/.$(@F).d
+@@ -113,7 +114,9 @@ SED_PC_CMD = 's|@version@|$(VERSION)|g; \
+
+ all: $(PROGRAMS) sparse.pc
+
+-install: $(INST_PROGRAMS) $(LIBS) $(LIB_H) sparse.pc
++all-installable: $(INST_PROGRAMS) $(LIBS) $(LIB_H) sparse.pc
++
++install: all-installable
+ $(Q)install -d $(DESTDIR)$(BINDIR)
+ $(Q)install -d $(DESTDIR)$(LIBDIR)
+ $(Q)install -d $(DESTDIR)$(MAN1DIR)
+diff --git a/parse.h b/parse.h
+index 6b21e23..b26bd03 100644
+--- a/parse.h
++++ b/parse.h
+@@ -35,10 +35,6 @@ struct statement {
+ struct /* declaration */ {
+ struct symbol_list *declaration;
+ };
+- struct /* label_arg */ {
+- struct symbol *label;
+- struct statement *label_statement;
+- };
+ struct {
+ struct expression *expression;
+ struct expression *context;