summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-07-12 22:37:05 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-07-12 22:37:40 +0100
commit4496cbadab513d1fad737d48637a5a731b37b537 (patch)
tree3774832e85a57caf254f99c39e19734657791214 /sys-devel/sparse/sparse-0.6.2.ebuild
parentgnome-extra/gnome-shell-extensions: bump to 3.36.2 (diff)
downloadgentoo-4496cbadab513d1fad737d48637a5a731b37b537.tar.gz
gentoo-4496cbadab513d1fad737d48637a5a731b37b537.tar.bz2
gentoo-4496cbadab513d1fad737d48637a5a731b37b537.zip
sys-devel/sparse: bump up to 0.6.2
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/sparse/sparse-0.6.2.ebuild')
-rw-r--r--sys-devel/sparse/sparse-0.6.2.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/sys-devel/sparse/sparse-0.6.2.ebuild b/sys-devel/sparse/sparse-0.6.2.ebuild
new file mode 100644
index 000000000000..8860a29313e7
--- /dev/null
+++ b/sys-devel/sparse/sparse-0.6.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils llvm multilib toolchain-funcs
+
+DESCRIPTION="C semantic parser"
+HOMEPAGE="https://sparse.wiki.kernel.org/index.php/Main_Page"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/devel/${PN}/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://www.kernel.org/pub/software/devel/${PN}/dist/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="gtk llvm sqlite test xml"
+RESTRICT="!test? ( test )"
+
+LLVM_MAX_SLOT=10
+
+RDEPEND="gtk? ( x11-libs/gtk+:2 )
+ llvm? ( sys-devel/llvm:${LLVM_MAX_SLOT}= )
+ sqlite? ( dev-db/sqlite:= )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ gtk? ( virtual/pkgconfig )
+ xml? ( virtual/pkgconfig )"
+
+pkg_setup() {
+ use llvm && llvm_pkg_setup
+}
+
+_emake() {
+ # Makefile does not allow for an easy override of flags.
+ # Collect them here and override default phases.
+ emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ CFLAGS="${CFLAGS}" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ \
+ HAVE_GTK=$(usex gtk) \
+ HAVE_LLVM=$(usex llvm) \
+ HAVE_SQLITE=$(usex sqlite) \
+ HAVE_LIBXML=$(usex xml) \
+ \
+ V=1 \
+ PREFIX="${EPREFIX}/usr" \
+ \
+ "$@"
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake check
+}
+
+src_install() {
+ _emake DESTDIR="${D}" install
+
+ dodoc FAQ README
+}