summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-10-02 09:55:08 +0200
committerMichał Górny <mgorny@gentoo.org>2016-10-02 09:57:55 +0200
commit01762e9615c4aedcb4bc562c7a9d5fe2fd36dacb (patch)
treef73fcd73ed4273e188bd014e954c14fd2c163538 /sys-devel
parentsys-devel/clang: Use target symlinks instead of wrappers (diff)
downloadgentoo-01762e9615c4aedcb4bc562c7a9d5fe2fd36dacb.tar.gz
gentoo-01762e9615c4aedcb4bc562c7a9d5fe2fd36dacb.tar.bz2
gentoo-01762e9615c4aedcb4bc562c7a9d5fe2fd36dacb.zip
sys-devel/llvm: Backport target syms from sys-devel/clang
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/llvm-3.9.0.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/sys-devel/llvm/llvm-3.9.0.ebuild b/sys-devel/llvm/llvm-3.9.0.ebuild
index 8ead13ed6220..4514dd0c239a 100644
--- a/sys-devel/llvm/llvm-3.9.0.ebuild
+++ b/sys-devel/llvm/llvm-3.9.0.ebuild
@@ -454,16 +454,12 @@ src_install() {
dosym "${i}-${clang_version}" "/usr/bin/${i}"
done
- # now create wrappers for all supported ABIs
+ # now create target symlinks for all supported ABIs
for abi in $(get_all_abis); do
- local abi_flags=$(get_abi_CFLAGS "${abi}")
local abi_chost=$(get_abi_CHOST "${abi}")
for i in "${clang_tools[@]}"; do
- cat > "${T}"/wrapper.tmp <<-_EOF_ || die
- #!${EPREFIX}/bin/sh
- exec "${i}-${clang_version}" ${abi_flags} "\${@}"
- _EOF_
- newbin "${T}"/wrapper.tmp "${abi_chost}-${i}-${clang_version}"
+ dosym "${i}-${clang_version}" \
+ "/usr/bin/${abi_chost}-${i}-${clang_version}"
dosym "${abi_chost}-${i}-${clang_version}" \
"/usr/bin/${abi_chost}-${i}"
done