summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorstefson <herrtimson@yahoo.de>2019-09-16 09:00:02 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-16 17:05:27 +0200
commit17d10010f7e4578ed704a2672c952b18f569727c (patch)
tree084cd2198eebbd19e2404d9f4d0beb0cb8065200 /sys-devel
parentsys-apps/fakeroot: bump to v1.24 (diff)
downloadgentoo-17d10010f7e4578ed704a2672c952b18f569727c.tar.gz
gentoo-17d10010f7e4578ed704a2672c952b18f569727c.tar.bz2
gentoo-17d10010f7e4578ed704a2672c952b18f569727c.zip
sys-devel/llvm: move dev-lang/perl to BDEPEND wrt #694460
dev-lang/perl is a build time dependency of llvm, only during cross compile it must be run by the host (CBUILD) and not the target (CHOST). Moving it to BDEPEND solves the issue of dev-lang/perl and friends getting pulled into the dependency graph as compile time dependencies during cross compile. BDEPEND has been introduced in EAPI=7, so the fix is only possible for >=llvm-9.x Closes: https://bugs.gentoo.org/694460 Signed-off-by: Steffen Kuhn <nielson2@yandex.com> Closes: https://github.com/gentoo/gentoo/pull/12941 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/llvm-10.0.0.9999.ebuild2
-rw-r--r--sys-devel/llvm/llvm-9.0.0.9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/sys-devel/llvm/llvm-10.0.0.9999.ebuild b/sys-devel/llvm/llvm-10.0.0.9999.ebuild
index 0fbb96cebb24..bacec8033f4e 100644
--- a/sys-devel/llvm/llvm-10.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-10.0.0.9999.ebuild
@@ -55,7 +55,6 @@ RDEPEND="
z3? ( >=sci-mathematics/z3-4.7.1:0=[${MULTILIB_USEDEP}] )"
# configparser-3.2 breaks the build (3.3 or none at all are fine)
DEPEND="${RDEPEND}
- dev-lang/perl
|| ( >=sys-devel/gcc-3.0 >=sys-devel/llvm-3.5
( >=sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
)
@@ -75,6 +74,7 @@ DEPEND="${RDEPEND}
# installed means llvm-config there will take precedence.
RDEPEND="${RDEPEND}
!sys-devel/llvm:0"
+BDEPEND="dev-lang/perl"
PDEPEND="sys-devel/llvm-common
gold? ( >=sys-devel/llvmgold-${SLOT} )"
diff --git a/sys-devel/llvm/llvm-9.0.0.9999.ebuild b/sys-devel/llvm/llvm-9.0.0.9999.ebuild
index abd71ac5d2c3..f294d0937069 100644
--- a/sys-devel/llvm/llvm-9.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-9.0.0.9999.ebuild
@@ -53,7 +53,6 @@ RDEPEND="
z3? ( >=sci-mathematics/z3-4.7.1:0=[${MULTILIB_USEDEP}] )"
# configparser-3.2 breaks the build (3.3 or none at all are fine)
DEPEND="${RDEPEND}
- dev-lang/perl
|| ( >=sys-devel/gcc-3.0 >=sys-devel/llvm-3.5
( >=sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
)
@@ -73,6 +72,7 @@ DEPEND="${RDEPEND}
# installed means llvm-config there will take precedence.
RDEPEND="${RDEPEND}
!sys-devel/llvm:0"
+BDEPEND="dev-lang/perl"
PDEPEND="sys-devel/llvm-common
gold? ( >=sys-devel/llvmgold-${SLOT} )"