summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-18 17:40:52 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-18 18:18:33 +0100
commit1c2a9591795b489aec85d4c5cf90258d24d24993 (patch)
treee253a17cb1f6945cdebf62b40091f165152bbb13 /sys-devel
parentsys-devel/lld: Include 11.* ebuilds for master (diff)
downloadgentoo-1c2a9591795b489aec85d4c5cf90258d24d24993.tar.gz
gentoo-1c2a9591795b489aec85d4c5cf90258d24d24993.tar.bz2
gentoo-1c2a9591795b489aec85d4c5cf90258d24d24993.zip
sys-devel/clang-common: Include 11.* ebuilds for master
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-common/clang-common-11.0.0.9999.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-devel/clang-common/clang-common-11.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-11.0.0.9999.ebuild
new file mode 100644
index 000000000000..18e41e0917da
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-11.0.0.9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
+llvm.org_set_globals
+S=${WORKDIR}/clang/utils
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+src_install() {
+ newbashcomp bash-autocomplete.sh clang
+}