summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-04-22 12:59:41 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-04-22 13:00:43 -0400
commit2680b1fb8a481eda59d7a9feabeb2e4306e221ef (patch)
tree568e86efcc817678602c06671adeca8d5c867a92 /sys-devel
parentdev-vcs/tig: Require xmlto for live ebuild (diff)
downloadgentoo-2680b1fb8a481eda59d7a9feabeb2e4306e221ef.tar.gz
gentoo-2680b1fb8a481eda59d7a9feabeb2e4306e221ef.tar.bz2
gentoo-2680b1fb8a481eda59d7a9feabeb2e4306e221ef.zip
sys-devel/ct-ng: version bump to 1.23.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/ct-ng/Manifest1
-rw-r--r--sys-devel/ct-ng/ct-ng-1.23.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-devel/ct-ng/Manifest b/sys-devel/ct-ng/Manifest
index 7e430711addf..674c284af489 100644
--- a/sys-devel/ct-ng/Manifest
+++ b/sys-devel/ct-ng/Manifest
@@ -1,2 +1,3 @@
DIST crosstool-ng-1.21.0.tar.bz2 19883048 SHA256 c64493dd033dee0eb25903e66cf53ff5113ee33d193a8ff1df7ebebe47bdac46 SHA512 ab2e341a920f43ef4c621579777b7e709b773dd38aeb68f2b1b567652497b912666ab841ff501f406c34b266e8dbe7859d67f63471972a2200044824848cf061 WHIRLPOOL 4d869c25741700afe4e9e398a8e124acd8cb513eba5609b85980c921966b08ac16ec2a884ed2a885fd44acdbbda01ff05623bce609152bcec5fa14b2c632202c
DIST crosstool-ng-1.22.0.tar.bz2 1621476 SHA256 d6338a9b33f9d972167049bbe76e88b1e9248466a53df08dcfe8bcfe849d8d83 SHA512 986c93435bd2115a7e19b3068aaa6deb9fea8056b389fc5cc578cbef3652514e1e794089cd9a4282f0e0bf73cf8d9e480b68aeabe7c16b627e7ad5afe46fcc9c WHIRLPOOL f339613d73be64032f7a0963e86457a9edf2d10105c73808ea4db0fe0ce1cd7df437995a92dbb2247d80401dbbb6103296a68a15362c434b622217529a89c309
+DIST crosstool-ng-1.23.0.tar.bz2 1782247 SHA256 1b76404960f2b35471b6385ba707b8a4712431820fe30063e435dad97ccb02b4 SHA512 1842d140b1c4f76783751eab60722e8077f356dfc9e9cc941d3c991a7e9bb23cb19e6bd7cd5c630cc87967853c55e0c16e415b222e546b5baaffb264ca799b69 WHIRLPOOL 5ecc52e6fed0fd1c54f9192f29686f2d77fa29d95086b40435eeb29fc0be9b7f2512ac881a696141608b0e7c0a9041012e8fd0c2f90bd854c651b3e77f47cfa5
diff --git a/sys-devel/ct-ng/ct-ng-1.23.0.ebuild b/sys-devel/ct-ng/ct-ng-1.23.0.ebuild
new file mode 100644
index 000000000000..42a61e626953
--- /dev/null
+++ b/sys-devel/ct-ng/ct-ng-1.23.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit bash-completion-r1
+
+DESCRIPTION="crosstool-ng is a tool to build cross-compiling toolchains"
+HOMEPAGE="http://crosstool-ng.org"
+MY_P=${P/ct/crosstool}
+SRC_URI="http://ymorin.is-a-geek.org/download/crosstool-ng/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="net-misc/curl
+ dev-util/gperf
+ dev-vcs/cvs
+ dev-vcs/subversion"
+
+S="${WORKDIR}/crosstool-ng-${PV}"
+
+src_install() {
+ emake DESTDIR="${D%/}" install
+ newbashcomp ${PN}.comp ${PN}
+ use doc && mv "${D}"/usr/share/doc/crosstool-ng/crosstool-ng-${PVR} \
+ "${D}"/usr/share/doc/
+ rm -rf "${D}"/usr/share/doc/crosstool-ng
+}