summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-07 08:29:46 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-07 10:15:16 +0100
commit2955e825d1a21db6d9376318ea5202a6350f1954 (patch)
tree5f4a73b320d868c2b29d2f78b85d86964fcbfe2c /sys-devel
parentdev-util/lldb: Bump to 9.0.1rc2 (diff)
downloadgentoo-2955e825d1a21db6d9376318ea5202a6350f1954.tar.gz
gentoo-2955e825d1a21db6d9376318ea5202a6350f1954.tar.bz2
gentoo-2955e825d1a21db6d9376318ea5202a6350f1954.zip
sys-devel/clang-common: Bump to 9.0.1rc2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-common/Manifest1
-rw-r--r--sys-devel/clang-common/clang-common-9.0.1_rc2.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-common/Manifest b/sys-devel/clang-common/Manifest
index ace4811162cb..4bad8d083c02 100644
--- a/sys-devel/clang-common/Manifest
+++ b/sys-devel/clang-common/Manifest
@@ -3,3 +3,4 @@ DIST cfe-7.1.0.src.tar.xz 12487872 BLAKE2B ca6ec9e45b94823de1dabf9e68f0c97cdd40b
DIST cfe-8.0.1.src.tar.xz 12810056 BLAKE2B 88cee0b6daa477ca0473c76efc45beb634f6194ecd3f45aaec3791e26b203c5dbd33c649435e0d97924096a72c727d76915bffc0b7ea305f24d5e5f06389c4a0 SHA512 1227b2d32052c70b4b494659849000188fce46fc31a71f3352ba8457ac0b0b17e4bc7c8589874c8586d55aa808ee6c1fceb7df501aafa33599f8df7bfd2b791d
DIST cfe-9.0.0.src.tar.xz 13533024 BLAKE2B 61fa57245d54930d09c2ff6024cdefb35592f7d1c644657b0aec9e7cc2dca29b45f08b8a2b716812025a438841e83ac3e30bb6f051498aa860533995ef7757b1 SHA512 83fcca5499102b375e620cdac97d75e6111ebed4ef10240859ddd8a88bc5b022703739d2eae0d8693c91892ad11fc6b531c0dbee62fbce68d3be595b94f0b1fe
DIST llvmorg-9.0.1-rc1.tar.gz 113193716 BLAKE2B 1ab52c778a139d33674589c27bf5a4d619dd4df49344b508c16de3ca6fad09c19480ceb615e0d9cf6d1981c7f28e106f087c0cd7bc2ccb844bec7099f5d227c2 SHA512 ed4b11cadbd57aa5f531d598e320a6bd54c67a8c713671af12ce62bc02283515ecbbc65ccbe3b0db3bad517cc4e6386cc3565be9eb9b9d06ca2a598428abf557
+DIST llvmorg-9.0.1-rc2.tar.gz 113203311 BLAKE2B 6e426060853e1587febedb75189444a1451236b713f800a4f3401c54318e48b0f5e0c484e9e4ef261faceed9b43b445a4153b061d4dadcc617047f9320b4f56a SHA512 fececd9365645920b9afdad1e94d5e10553ad4a39d84b3ac811b86014c395d51f7e4dabe54bb095a99481400c408bee3c9a2044168724d5e094e3258587a5d2c
diff --git a/sys-devel/clang-common/clang-common-9.0.1_rc2.ebuild b/sys-devel/clang-common/clang-common-9.0.1_rc2.ebuild
new file mode 100644
index 000000000000..d1bfe71d2f80
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-9.0.1_rc2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
+llvm.org_set_globals
+S=${WORKDIR}/clang/utils
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+src_install() {
+ newbashcomp bash-autocomplete.sh clang
+}