summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-01-25 21:45:35 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-01-25 21:45:48 +0000
commit385f248b765e327e6eccaf423c55e0f2f82a3e4b (patch)
tree767f2d64f72b5a61b3c91e4ad2fa7912de1a82a2 /sys-devel
parentmedia-libs/libnsgif: Use BDEPEND (diff)
downloadgentoo-385f248b765e327e6eccaf423c55e0f2f82a3e4b.tar.gz
gentoo-385f248b765e327e6eccaf423c55e0f2f82a3e4b.tar.bz2
gentoo-385f248b765e327e6eccaf423c55e0f2f82a3e4b.zip
sys-devel/crossdev: bump up to 20200125
Two new changes: - disable default ssp support on x86 and ppc on musl, bug #706210 - migrate from package.keywords to package.accept_keywords, bug #706212 Bug: https://bugs.gentoo.org/706210 Closes: https://bugs.gentoo.org/706212 Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/crossdev/Manifest1
-rw-r--r--sys-devel/crossdev/crossdev-20200125.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index b09530fb3fb1..5f295ac037ed 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -1 +1,2 @@
DIST crossdev-20191222.tar.xz 27320 BLAKE2B 375e0ccb7bfd5c5c365b9c874a7dbf75207843b68dbe6d4cf9da07b36efb7b3bb1e6c84f85268fea6c71d6afc1e284f9bd1dcfeca5536d0947f8d3a3f5344ca9 SHA512 ad32f2231663f312b2b35bdea81c9ddac584d13f9affd496f36cbed072a97e6f80deb3436dcbea184621a4bd86bb25d52fb0434208226a3d743f0f664cd91fd0
+DIST crossdev-20200125.tar.xz 27380 BLAKE2B 4871b3ba1130c8d2e4df263aea155f95352417e65dabe64968cf9cc2628f9a1ae32a7e569cdea73a04d32d05396b0a83720bbd712a5f5b703606692e6b61516b SHA512 a4db1d09179b23f032af59c4857c3ab58d7944633b0c612a1f8aa0ecc38201f960cc1da761f34288568bb7f3434fe4da5094b4d4445be047da8838a096f6c606
diff --git a/sys-devel/crossdev/crossdev-20200125.ebuild b/sys-devel/crossdev/crossdev-20200125.ebuild
new file mode 100644
index 000000000000..e37579ff62fd
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20200125.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Crossdev"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=sys-apps/portage-2.1
+ >=app-portage/portage-utils-0.55
+ app-shells/bash
+ sys-apps/gentoo-functions
+"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+}