summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-10-03 10:42:29 +0200
committerMichał Górny <mgorny@gentoo.org>2016-10-03 11:38:32 +0200
commit4819e144ca29b2a49eac242f8418880c10435543 (patch)
tree6e534ba3a3183149d9b6c9eebcc166f7f2a01fe8 /sys-devel
parentpackage.mask: Add sys-devel/clang-runtime to LLVM 3.9 mask (diff)
downloadgentoo-4819e144ca29b2a49eac242f8418880c10435543.tar.gz
gentoo-4819e144ca29b2a49eac242f8418880c10435543.tar.bz2
gentoo-4819e144ca29b2a49eac242f8418880c10435543.zip
sys-devel/clang-runtime: Introduce the runtime metapackage
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-3.9.0.ebuild19
-rw-r--r--sys-devel/clang-runtime/clang-runtime-9999.ebuild24
-rw-r--r--sys-devel/clang-runtime/metadata.xml13
3 files changed, 56 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-3.9.0.ebuild b/sys-devel/clang-runtime/clang-runtime-3.9.0.ebuild
new file mode 100644
index 000000000000..0388e2c324ff
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-3.9.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="http://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libcxx openmp"
+
+# compiler-rt is installed unconditionally
+RDEPEND="
+ libcxx? ( ~sys-libs/libcxx-${PV} )
+ openmp? ( ~sys-libs/libomp-${PV} )"
diff --git a/sys-devel/clang-runtime/clang-runtime-9999.ebuild b/sys-devel/clang-runtime/clang-runtime-9999.ebuild
new file mode 100644
index 000000000000..a29a5419eb1b
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="http://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="0"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV} )
+ )
+ libcxx? ( ~sys-libs/libcxx-${PV} )
+ openmp? ( ~sys-libs/libomp-${PV} )"
+
+REQUIRED_USE="sanitize? ( compiler-rt )"
diff --git a/sys-devel/clang-runtime/metadata.xml b/sys-devel/clang-runtime/metadata.xml
new file mode 100644
index 000000000000..f761b620168e
--- /dev/null
+++ b/sys-devel/clang-runtime/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>llvm@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="compiler-rt">Install <pkg>sys-libs/compiler-rt</pkg> for -rtlib=compiler-rt</flag>
+ <flag name="libcxx">Install <pkg>sys-libs/libcxx</pkg> for -stdlib=libc++</flag>
+ <flag name="openmp">Install <pkg>sys-libs/libomp</pkg> for -fopenmp support</flag>
+ <flag name="sanitize">Enable compiler-rt sanitizer (-fsanitize*) support</flag>
+ </use>
+</pkgmetadata>