summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-04-27 23:40:02 +1200
committerLars Wendler <polynomial-c@gentoo.org>2017-04-27 15:42:18 +0200
commit50932475bceaaa0499b1d1e0daf78e5e8f7c1446 (patch)
treec8d339403e7230cf10896127c40ab4b0bbcc22ec /sys-devel
parentsys-apps/systemd: depend on lxml unconditionally (diff)
downloadgentoo-50932475bceaaa0499b1d1e0daf78e5e8f7c1446.tar.gz
gentoo-50932475bceaaa0499b1d1e0daf78e5e8f7c1446.tar.bz2
gentoo-50932475bceaaa0499b1d1e0daf78e5e8f7c1446.zip
sys-devel/autoconf: Add perl-5.26 patch re bug #613790
This fixes the unescaped "{" issue. -r1 bump necessary as end users must have this patch applied to their installs otherwise autoscan will be broken after upgrading perl. autoconf does not subslot dep on perl, so there are no guarantees that a rebuild will happen to propagate this patch Hence, -r1 fix Bug: https://bugs.gentoo.org/613790 Package-Manager: Portage-2.3.4, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4500
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/autoconf/autoconf-2.69-r3.ebuild (renamed from sys-devel/autoconf/autoconf-2.69-r2.ebuild)1
-rw-r--r--sys-devel/autoconf/files/autoconf-2.69-perl-5.26.patch28
2 files changed, 29 insertions, 0 deletions
diff --git a/sys-devel/autoconf/autoconf-2.69-r2.ebuild b/sys-devel/autoconf/autoconf-2.69-r3.ebuild
index 0acd57e4e778..37354a400d9c 100644
--- a/sys-devel/autoconf/autoconf-2.69-r2.ebuild
+++ b/sys-devel/autoconf/autoconf-2.69-r3.ebuild
@@ -36,5 +36,6 @@ src_prepare() {
# usr/bin/libtool is provided by binutils-apple, need gnu libtool
[[ ${CHOST} == *-darwin* ]] && \
PATCHES+=( "${FILESDIR}"/${PN}-2.61-darwin.patch )
+ PATCHES+=( "${FILESDIR}"/${PN}-2.69-perl-5.26.patch )
toolchain-autoconf_src_prepare
}
diff --git a/sys-devel/autoconf/files/autoconf-2.69-perl-5.26.patch b/sys-devel/autoconf/files/autoconf-2.69-perl-5.26.patch
new file mode 100644
index 000000000000..b3d7888ca722
--- /dev/null
+++ b/sys-devel/autoconf/files/autoconf-2.69-perl-5.26.patch
@@ -0,0 +1,28 @@
+From e5654a5591884b92633c7785f325626711e7f7aa Mon Sep 17 00:00:00 2001
+From: Paul Eggert <eggert@cs.ucla.edu>
+Date: Tue, 29 Jan 2013 13:46:48 -0800
+Subject: [PATCH] autoscan: port to perl 5.17
+
+* bin/autoscan.in (scan_sh_file): Escape '{'. This avoids a
+feature that is deprecated in Perl 5.17. Reported by Ray Lauff in
+<http://lists.gnu.org/archive/html/bug-autoconf/2013-01/msg00059.html>.
+---
+ bin/autoscan.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/bin/autoscan.in b/bin/autoscan.in
+index 993a750..db1df79 100644
+--- a/bin/autoscan.in
++++ b/bin/autoscan.in
+@@ -358,7 +358,7 @@ sub scan_sh_file ($)
+ {
+ # Strip out comments and variable references.
+ s/#.*//;
+- s/\${[^\}]*}//g;
++ s/\$\{[^\}]*}//g;
+ s/@[^@]*@//g;
+
+ # Tokens in the code.
+--
+1.9.1
+