summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-01-20 09:37:42 -0500
committerMichael Orlitzky <mjo@gentoo.org>2022-01-20 09:40:30 -0500
commit5ad0c179fe9c6c5cbfe3edde28f2759386675bb1 (patch)
treeda7c198f326964510bdbb55301c8ec542dbb2b35 /sys-devel
parentpython-utils-r1.eclass: Run sphinx-build via EPYTHON (diff)
downloadgentoo-5ad0c179fe9c6c5cbfe3edde28f2759386675bb1.tar.gz
gentoo-5ad0c179fe9c6c5cbfe3edde28f2759386675bb1.tar.bz2
gentoo-5ad0c179fe9c6c5cbfe3edde28f2759386675bb1.zip
sys-devel/mold: new revision sans "GNU gold" in --version.
The new mold-1.0.1-r1 includes upstream commit cea6a569afa5 which removes the string "GNU gold" from mold's --version string. This is necessary on Gentoo to prevent false positives from tc-ld-is-gold() in the toolchain-funcs eclass. Closes: https://bugs.gentoo.org/831478 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/mold/files/mold-1.0.1-no-gold-in-version.patch50
-rw-r--r--sys-devel/mold/mold-1.0.1-r1.ebuild (renamed from sys-devel/mold/mold-1.0.1.ebuild)4
2 files changed, 53 insertions, 1 deletions
diff --git a/sys-devel/mold/files/mold-1.0.1-no-gold-in-version.patch b/sys-devel/mold/files/mold-1.0.1-no-gold-in-version.patch
new file mode 100644
index 000000000000..429e55cc51a9
--- /dev/null
+++ b/sys-devel/mold/files/mold-1.0.1-no-gold-in-version.patch
@@ -0,0 +1,50 @@
+From cea6a569afa544826c91fda7ef0f9941f50c9459 Mon Sep 17 00:00:00 2001
+From: Rui Ueyama <ruiu@cs.stanford.edu>
+Date: Wed, 12 Jan 2022 16:31:04 +0900
+Subject: [PATCH] [ELF] Remove "GNU gold" from the --version string
+
+That substring was introduced in de7ba9014f9d9d70b9173c4bfac6c3433186ba49
+to appease Gentoo's dev-libs/jansson-2.13.1-r1 package. But I think I
+shouldn't done that from the beginning to avoid the sitaution of the
+"User-Agent" string of the web browser, which everybody claims they
+are Mozilla, AppleWebKit, Chrome and Safari simultaneously.
+---
+ main.cc | 4 ++--
+ test/elf/version.sh | 6 +++---
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/main.cc b/main.cc
+index 38a41cdf..8831f7f2 100644
+--- a/main.cc
++++ b/main.cc
+@@ -26,10 +26,10 @@ std::string_view errno_string() {
+
+ #ifdef GIT_HASH
+ const std::string mold_version =
+- "mold " MOLD_VERSION " (" GIT_HASH "; compatible with GNU ld and GNU gold)";
++ "mold " MOLD_VERSION " (" GIT_HASH "; compatible with GNU ld)";
+ #else
+ const std::string mold_version =
+- "mold " MOLD_VERSION " (compatible with GNU ld and GNU gold)";
++ "mold " MOLD_VERSION " (compatible with GNU ld)";
+ #endif
+
+ void cleanup() {
+diff --git a/test/elf/version.sh b/test/elf/version.sh
+index ae52b504..4ca576ef 100755
+--- a/test/elf/version.sh
++++ b/test/elf/version.sh
+@@ -10,10 +10,10 @@ mold="$(pwd)/mold"
+ t=out/test/elf/$testname
+ mkdir -p $t
+
+-"$mold" -v | grep -q 'mold .*compatible with GNU ld and GNU gold'
+-"$mold" --version | grep -q 'mold .*compatible with GNU ld and GNU gold'
++"$mold" -v | grep -q 'mold .*compatible with GNU ld'
++"$mold" --version | grep -q 'mold .*compatible with GNU ld'
+
+-"$mold" -V | grep -q 'mold .*compatible with GNU ld and GNU gold'
++"$mold" -V | grep -q 'mold .*compatible with GNU ld'
+ "$mold" -V | grep -q elf_x86_64
+ "$mold" -V | grep -q elf_i386
+
diff --git a/sys-devel/mold/mold-1.0.1.ebuild b/sys-devel/mold/mold-1.0.1-r1.ebuild
index 9751b231a53f..e0cd2503b621 100644
--- a/sys-devel/mold/mold-1.0.1.ebuild
+++ b/sys-devel/mold/mold-1.0.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -31,6 +31,8 @@ RDEPEND=">=dev-cpp/tbb-2021.4.0:=
)"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/${P}-no-gold-in-version.patch" )
+
src_prepare() {
default