summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-05-12 12:58:07 +0200
committerMichał Górny <mgorny@gentoo.org>2016-05-12 13:48:41 +0200
commit8c3d7ed8dfa3e1355338e02c675d3e76d63846b4 (patch)
treef32403f0548a02dba641e13f036ed9bfc9054e44 /sys-devel
parentsys-devel/llvm: Backport upstream patch for gcc4.9 Gentoo header paths (diff)
downloadgentoo-8c3d7ed8dfa3e1355338e02c675d3e76d63846b4.tar.gz
gentoo-8c3d7ed8dfa3e1355338e02c675d3e76d63846b4.tar.bz2
gentoo-8c3d7ed8dfa3e1355338e02c675d3e76d63846b4.zip
sys-devel/llvm: Update compiler-rt build patch for current git
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/files/cmake/compiler-rt-3.9-cmake-Install-compiler-rt-into-usr-lib-without-suffi.patch26
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild2
2 files changed, 27 insertions, 1 deletions
diff --git a/sys-devel/llvm/files/cmake/compiler-rt-3.9-cmake-Install-compiler-rt-into-usr-lib-without-suffi.patch b/sys-devel/llvm/files/cmake/compiler-rt-3.9-cmake-Install-compiler-rt-into-usr-lib-without-suffi.patch
new file mode 100644
index 000000000000..a09de901024d
--- /dev/null
+++ b/sys-devel/llvm/files/cmake/compiler-rt-3.9-cmake-Install-compiler-rt-into-usr-lib-without-suffi.patch
@@ -0,0 +1,26 @@
+From 380b8faadc3fc66f9aa0528bd3578464b317c31e Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Thu, 12 May 2016 08:25:48 +0200
+Subject: [PATCH] cmake: Install compiler-rt to a directory without libdir
+ suffix
+
+---
+ cmake/base-config-ix.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cmake/base-config-ix.cmake b/cmake/base-config-ix.cmake
+index 5d0502c..ce16ce9 100644
+--- a/projects/compiler-rt/cmake/base-config-ix.cmake
++++ b/projects/compiler-rt/cmake/base-config-ix.cmake
+@@ -18,7 +18,7 @@ if (NOT COMPILER_RT_STANDALONE_BUILD)
+ # Setup the paths where compiler-rt runtimes and headers should be stored.
+ set(COMPILER_RT_OUTPUT_DIR ${LLVM_LIBRARY_OUTPUT_INTDIR}/clang/${CLANG_VERSION})
+ set(COMPILER_RT_EXEC_OUTPUT_DIR ${LLVM_RUNTIME_OUTPUT_INTDIR})
+- set(COMPILER_RT_INSTALL_PATH lib${LLVM_LIBDIR_SUFFIX}/clang/${CLANG_VERSION})
++ set(COMPILER_RT_INSTALL_PATH lib/clang/${CLANG_VERSION})
+ option(COMPILER_RT_INCLUDE_TESTS "Generate and build compiler-rt unit tests."
+ ${LLVM_INCLUDE_TESTS})
+ option(COMPILER_RT_ENABLE_WERROR "Fail and stop if warning is triggered"
+--
+2.8.2
+
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 0b8dddcc6f63..dda696c3d753 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -179,7 +179,7 @@ src_prepare() {
# Install clang runtime into /usr/lib/clang
# https://llvm.org/bugs/show_bug.cgi?id=23792
eapply "${FILESDIR}"/cmake/clang-0001-Install-clang-runtime-into-usr-lib-without-suffix-3.8.patch
- eapply "${FILESDIR}"/cmake/compiler-rt-0001-cmake-Install-compiler-rt-into-usr-lib-without-suffi.patch
+ eapply "${FILESDIR}"/cmake/compiler-rt-3.9-cmake-Install-compiler-rt-into-usr-lib-without-suffi.patch
# Make it possible to override CLANG_LIBDIR_SUFFIX
# (that is used only to find LLVMgold.so)