summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-23 08:48:48 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-23 08:48:48 +0100
commitafd2073e15e81865bac55c07c1062217d963279c (patch)
tree53d85c14ce5d0b9273c24906cf939b63052595df /sys-devel
parentsys-devel/lld: Bump to 9.0.1_rc1 (diff)
downloadgentoo-afd2073e15e81865bac55c07c1062217d963279c.tar.gz
gentoo-afd2073e15e81865bac55c07c1062217d963279c.tar.bz2
gentoo-afd2073e15e81865bac55c07c1062217d963279c.zip
sys-devel/clang-common: Bump to 9.0.1_rc1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-common/Manifest1
-rw-r--r--sys-devel/clang-common/clang-common-9.0.1_rc1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-common/Manifest b/sys-devel/clang-common/Manifest
index eef8f2eba283..ace4811162cb 100644
--- a/sys-devel/clang-common/Manifest
+++ b/sys-devel/clang-common/Manifest
@@ -2,3 +2,4 @@ DIST cfe-6.0.1.src.tar.xz 11905772 BLAKE2B abb60e9f9827d1d8a24f0aaf8a1d1e3297929
DIST cfe-7.1.0.src.tar.xz 12487872 BLAKE2B ca6ec9e45b94823de1dabf9e68f0c97cdd40b5d2a5e5e15d4b2393f6d7fbdee72a541b957cc22ce4cb726d8ee7190228320941d5713aeb59695673b9e9070ceb SHA512 1cd0b80f32aa4de1118c0c676ba96b1fc78b7ff929b01b6589dfe9b4669e599ac8cfb8f5a0abcd3487594193a7dec06b29530ec3fc03042c20a160f0477a79fd
DIST cfe-8.0.1.src.tar.xz 12810056 BLAKE2B 88cee0b6daa477ca0473c76efc45beb634f6194ecd3f45aaec3791e26b203c5dbd33c649435e0d97924096a72c727d76915bffc0b7ea305f24d5e5f06389c4a0 SHA512 1227b2d32052c70b4b494659849000188fce46fc31a71f3352ba8457ac0b0b17e4bc7c8589874c8586d55aa808ee6c1fceb7df501aafa33599f8df7bfd2b791d
DIST cfe-9.0.0.src.tar.xz 13533024 BLAKE2B 61fa57245d54930d09c2ff6024cdefb35592f7d1c644657b0aec9e7cc2dca29b45f08b8a2b716812025a438841e83ac3e30bb6f051498aa860533995ef7757b1 SHA512 83fcca5499102b375e620cdac97d75e6111ebed4ef10240859ddd8a88bc5b022703739d2eae0d8693c91892ad11fc6b531c0dbee62fbce68d3be595b94f0b1fe
+DIST llvmorg-9.0.1-rc1.tar.gz 113193716 BLAKE2B 1ab52c778a139d33674589c27bf5a4d619dd4df49344b508c16de3ca6fad09c19480ceb615e0d9cf6d1981c7f28e106f087c0cd7bc2ccb844bec7099f5d227c2 SHA512 ed4b11cadbd57aa5f531d598e320a6bd54c67a8c713671af12ce62bc02283515ecbbc65ccbe3b0db3bad517cc4e6386cc3565be9eb9b9d06ca2a598428abf557
diff --git a/sys-devel/clang-common/clang-common-9.0.1_rc1.ebuild b/sys-devel/clang-common/clang-common-9.0.1_rc1.ebuild
new file mode 100644
index 000000000000..d1bfe71d2f80
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-9.0.1_rc1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
+llvm.org_set_globals
+S=${WORKDIR}/clang/utils
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+src_install() {
+ newbashcomp bash-autocomplete.sh clang
+}