summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-17 23:00:16 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-17 23:00:50 +0200
commitb3b2e75d5057887483c91077989db4f3f85c7b0a (patch)
treed71a41287e372e3547cb66a7843a395d894d9b23 /sys-devel
parentsys-devel/clang: Use BDEPEND semi-properly (diff)
downloadgentoo-b3b2e75d5057887483c91077989db4f3f85c7b0a.tar.gz
gentoo-b3b2e75d5057887483c91077989db4f3f85c7b0a.tar.bz2
gentoo-b3b2e75d5057887483c91077989db4f3f85c7b0a.zip
sys-devel/lld: Use BDEPEND semi-properly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/lld/lld-10.0.0.9999.ebuild6
-rw-r--r--sys-devel/lld/lld-9.0.0.9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/sys-devel/lld/lld-10.0.0.9999.ebuild b/sys-devel/lld/lld-10.0.0.9999.ebuild
index 89abb313a970..2469a9bd7046 100644
--- a/sys-devel/lld/lld-10.0.0.9999.ebuild
+++ b/sys-devel/lld/lld-10.0.0.9999.ebuild
@@ -23,14 +23,14 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="~sys-devel/llvm-${PV}"
-DEPEND="${RDEPEND}
- test? ( $(python_gen_any_dep "~dev-python/lit-${PV}[\${PYTHON_USEDEP}]") )"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( $(python_gen_any_dep "~dev-python/lit-${PV}[\${PYTHON_USEDEP}]") )"
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
python_check_deps() {
- has_version "dev-python/lit[${PYTHON_USEDEP}]"
+ has_version -b "dev-python/lit[${PYTHON_USEDEP}]"
}
pkg_setup() {
diff --git a/sys-devel/lld/lld-9.0.0.9999.ebuild b/sys-devel/lld/lld-9.0.0.9999.ebuild
index 216166a79aff..6935200f15c6 100644
--- a/sys-devel/lld/lld-9.0.0.9999.ebuild
+++ b/sys-devel/lld/lld-9.0.0.9999.ebuild
@@ -24,14 +24,14 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="~sys-devel/llvm-${PV}"
-DEPEND="${RDEPEND}
- test? ( $(python_gen_any_dep "~dev-python/lit-${PV}[\${PYTHON_USEDEP}]") )"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( $(python_gen_any_dep "~dev-python/lit-${PV}[\${PYTHON_USEDEP}]") )"
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
python_check_deps() {
- has_version "dev-python/lit[${PYTHON_USEDEP}]"
+ has_version -b "dev-python/lit[${PYTHON_USEDEP}]"
}
pkg_setup() {