summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-12-24 09:44:17 -0500
committerAnthony G. Basile <blueness@gentoo.org>2017-12-24 09:44:17 -0500
commitb7dabea6d086f59e1d1b899709cb62bc2a4ddab9 (patch)
treeec8d3dacc9bc1b80af1c5684708b42c9598c3d7d /sys-devel
parentmedia-gfx/shotwell: Version bump to shotwell-0.27.2 (diff)
downloadgentoo-b7dabea6d086f59e1d1b899709cb62bc2a4ddab9.tar.gz
gentoo-b7dabea6d086f59e1d1b899709cb62bc2a4ddab9.tar.bz2
gentoo-b7dabea6d086f59e1d1b899709cb62bc2a4ddab9.zip
sys-devel/bin86: fix build on x86 musl, bump to EAPI=6
ld/bindef.h uses brain-dead #ifdef logic in deciding whether to include <a.out.h> on x86. By undefining __linux__ we fix this on musl systems. Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bin86/bin86-0.16.21.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-devel/bin86/bin86-0.16.21.ebuild b/sys-devel/bin86/bin86-0.16.21.ebuild
index 3c587b03ca5e..189d5bc75ed8 100644
--- a/sys-devel/bin86/bin86-0.16.21.ebuild
+++ b/sys-devel/bin86/bin86-0.16.21.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
inherit toolchain-funcs eutils
@@ -15,6 +15,7 @@ KEYWORDS="amd64 ~arm64 ~ppc ~ppc64 x86 ~amd64-fbsd ~x86-fbsd"
IUSE=""
src_prepare() {
+ use elibc_musl && CPPFLAGS="${CPPFLAGS} -U__linux__"
sed -i \
-e '/^PREFIX/s:=.*:=$(DESTDIR)/usr:' \
-e '/^MANDIR/s:)/man/man1:)/share/man/man1:' \
@@ -23,6 +24,7 @@ src_prepare() {
-e "/^LDFLAGS/s:=.*:=${LDFLAGS}:" \
Makefile || die
epatch "${FILESDIR}"/${PN}-0.16.17-amd64-build.patch
+ eapply_user
tc-export CC
}