summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-06-26 16:48:17 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-27 21:18:03 +0200
commitbecb5fc53bed283a5b0d79fd9bad7d41d8b48db6 (patch)
treed2e55749b5199677bda298ea27423f3c8128c252 /sys-devel
parentsys-libs/libomp: Bump to 4.0.1 (diff)
downloadgentoo-becb5fc53bed283a5b0d79fd9bad7d41d8b48db6.tar.gz
gentoo-becb5fc53bed283a5b0d79fd9bad7d41d8b48db6.tar.bz2
gentoo-becb5fc53bed283a5b0d79fd9bad7d41d8b48db6.zip
sys-devel/clang-runtime: Bump to 4.0.1
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-4.0.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-4.0.1.ebuild b/sys-devel/clang-runtime/clang-runtime-4.0.1.ebuild
new file mode 100644
index 000000000000..511e1c11c4b9
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-4.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="http://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="${PV%_*}"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
+
+REQUIRED_USE="sanitize? ( compiler-rt )"