summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-12 11:13:49 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-12 14:38:12 +0200
commitfd3a113bcd63e9cc2cb8e063a4f66ce3d8fed2a2 (patch)
treeb9be540bd12d9174e168799980d83418b9a294cd /sys-devel
parentsys-libs/libomp: Bump to 11.0.0 final (diff)
downloadgentoo-fd3a113bcd63e9cc2cb8e063a4f66ce3d8fed2a2.tar.gz
gentoo-fd3a113bcd63e9cc2cb8e063a4f66ce3d8fed2a2.tar.bz2
gentoo-fd3a113bcd63e9cc2cb8e063a4f66ce3d8fed2a2.zip
sys-devel/clang-runtime: Bump to 11.0.0 final
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-11.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-11.0.0.ebuild b/sys-devel/clang-runtime/clang-runtime-11.0.0.ebuild
new file mode 100644
index 000000000000..1db47ec0dcf5
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-11.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+PROPERTIES="live"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"