summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-28 13:42:57 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-28 13:42:57 +0100
commitc2802ba9b7b11cc1add9556e6a858d576fd1e861 (patch)
treed20f8c812514adffde85e01e7ce3272328513e92 /sys-fabric/libcxgb3
parentnet-print/cndrvcups-common-lb: fix build with gcc-10 (diff)
downloadgentoo-c2802ba9b7b11cc1add9556e6a858d576fd1e861.tar.gz
gentoo-c2802ba9b7b11cc1add9556e6a858d576fd1e861.tar.bz2
gentoo-c2802ba9b7b11cc1add9556e6a858d576fd1e861.zip
sys-fabric/libcxgb3: Port to EAPI 6
Closes: https://bugs.gentoo.org/706596 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-fabric/libcxgb3')
-rw-r--r--sys-fabric/libcxgb3/files/libcxgb3-1.3.1-fno-common.patch41
-rw-r--r--sys-fabric/libcxgb3/libcxgb3-1.3.1-r2.ebuild5
2 files changed, 44 insertions, 2 deletions
diff --git a/sys-fabric/libcxgb3/files/libcxgb3-1.3.1-fno-common.patch b/sys-fabric/libcxgb3/files/libcxgb3-1.3.1-fno-common.patch
new file mode 100644
index 000000000000..e23ffa8682c2
--- /dev/null
+++ b/sys-fabric/libcxgb3/files/libcxgb3-1.3.1-fno-common.patch
@@ -0,0 +1,41 @@
+--- a/src/cxio_wr.h
++++ b/src/cxio_wr.h
+@@ -638,9 +638,9 @@ static inline unsigned t3_cq_depth(struct t3_cq *cq)
+ return (1UL<<cq->size_log2);
+ }
+
+-unsigned long iwch_page_size;
+-unsigned long iwch_page_shift;
+-unsigned long iwch_page_mask;
++extern unsigned long iwch_page_size;
++extern unsigned long iwch_page_shift;
++extern unsigned long iwch_page_mask;
+
+ #define PAGE_ALIGN(x) (((x) + iwch_page_mask) & ~iwch_page_mask)
+
+--- a/src/iwch.c
++++ b/src/iwch.c
+@@ -63,6 +63,10 @@
+ .device = PCI_DEVICE_ID_CHELSIO_##d, \
+ .type = CHELSIO_##t }
+
++extern unsigned long iwch_page_size;
++extern unsigned long iwch_page_mask;
++extern unsigned long iwch_page_shift;
++
+ struct {
+ unsigned vendor;
+ unsigned device;
+--- a/src/verbs.c
++++ b/src/verbs.c
+@@ -45,6 +45,10 @@
+ #include "iwch.h"
+ #include "iwch-abi.h"
+
++unsigned long iwch_page_size;
++unsigned long iwch_page_shift;
++unsigned long iwch_page_mask;
++
+ int iwch_query_device(struct ibv_context *context, struct ibv_device_attr *attr)
+ {
+ struct ibv_query_device cmd;
diff --git a/sys-fabric/libcxgb3/libcxgb3-1.3.1-r2.ebuild b/sys-fabric/libcxgb3/libcxgb3-1.3.1-r2.ebuild
index 2d5bc5c6608d..20ffdc32534e 100644
--- a/sys-fabric/libcxgb3/libcxgb3-1.3.1-r2.ebuild
+++ b/sys-fabric/libcxgb3/libcxgb3-1.3.1-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
OFED_VER="3.12"
OFED_RC="1"
@@ -12,12 +12,13 @@ inherit openib
DESCRIPTION="OpenIB - driver for Chelsio T3-based iWARP (RDMA over IP/ethernet)"
KEYWORDS="amd64 ~x86 ~amd64-linux"
-IUSE=""
DEPEND="sys-fabric/libibverbs:${SLOT}"
RDEPEND="${DEPEND}"
block_other_ofed_versions
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
src_configure() {
econf --disable-static
}