summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2021-04-06 21:08:34 -0700
committerZac Medico <zmedico@gentoo.org>2021-04-06 21:09:36 -0700
commitd05a5ad86b99f86952cc3050d2e49af7ae4598a5 (patch)
tree2c54d37472e1b359e670a600c03c4b02cc4d7de2 /sys-fabric/mstflint
parentdev-libs/tree-sitter: Revision bump after upstream changing release tag (diff)
downloadgentoo-d05a5ad86b99f86952cc3050d2e49af7ae4598a5.tar.gz
gentoo-d05a5ad86b99f86952cc3050d2e49af7ae4598a5.tar.bz2
gentoo-d05a5ad86b99f86952cc3050d2e49af7ae4598a5.zip
sys-fabric/mstflint: Bump to version 4.16.0_p2
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'sys-fabric/mstflint')
-rw-r--r--sys-fabric/mstflint/Manifest1
-rw-r--r--sys-fabric/mstflint/mstflint-4.16.0_p2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/sys-fabric/mstflint/Manifest b/sys-fabric/mstflint/Manifest
index 525d0558b8f4..a779f53f9aaf 100644
--- a/sys-fabric/mstflint/Manifest
+++ b/sys-fabric/mstflint/Manifest
@@ -2,3 +2,4 @@ DIST mstflint-4.10.0_p3.tar.gz 3208065 BLAKE2B 9d27bc41f3af4af2d430814a892bc26b3
DIST mstflint-4.11.0_p5.tar.gz 3622665 BLAKE2B 119d1ca04eaf3ebc2e4b8175525fdc87079b27742013f210f8c38d2ac0e83b46c555e4b8b49d7f1562180473c0873456932939e942b1050e9c952a2e3172185a SHA512 c98f24acda519e62fd8db8e170c39c8ffe69b980bc2c9a167f20cfcb2575038648e463de0c7dfad3ddebe098b8a466640b7a125901c033f193a42ef1bfef00d8
DIST mstflint-4.13.3_p2.tar.gz 3809937 BLAKE2B bfe0d5a531a26547779f2e9377c4c6f393c28623d56c87a1f0210a0fbb767a43f5186c481609722ef2e5066bcdf0110009468b047ca0a8b25c096f4802b43229 SHA512 bd7e937eaed30c4b4479c3bc184d9bd8edff9aba23824fdd6a82f0e62d319854aa74954c783eb483074e322eec94f9a0cd5bd6a0ff4de2422f9b011680324706
DIST mstflint-4.14.0_p3.tar.gz 4012564 BLAKE2B 4203c398665cbc7a0e9f86158e58270c903f546372aecf697c09b75f7fc44944304a4c5f1524362d442ed8e16f5dd9f35fe08ec638c5c556ed182cbac9f1c27b SHA512 c27872e34443df24fb152f2837d2fa31a7a459eff859654d00c815fc942182dc48d18991e83b79cc99bbd5fafe5b721b69e9bee9c927e2d54581eb78d7a5548e
+DIST mstflint-4.16.0_p2.tar.gz 4534457 BLAKE2B c199cd0b4eed8ecc20b8ab89235035b7ad258fe583c464dafb31a1e5ba8f6cfd745b132ff12631fa0d98c2d94f16ca69c908c0b6ad94391ec1a3e56ba9967d59 SHA512 03a6b055384b9fab44a31ba6f2de02d1580e08af981c1cad5111a96279872ea960024bfa9debbbdb36019b88713906c3c59d3910a11f169ad5f3a0090bc6c7df
diff --git a/sys-fabric/mstflint/mstflint-4.16.0_p2.ebuild b/sys-fabric/mstflint/mstflint-4.16.0_p2.ebuild
new file mode 100644
index 000000000000..bac06d183ae9
--- /dev/null
+++ b/sys-fabric/mstflint/mstflint-4.16.0_p2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Mstflint - an open source version of MFT (Mellanox Firmware Tools)"
+HOMEPAGE="https://github.com/Mellanox/mstflint"
+LICENSE="|| ( GPL-2 BSD-2 )"
+KEYWORDS="~amd64 ~x86"
+EGIT_COMMIT="bd8852742cbd5d4d5eb0d67e000275c953cc0820"
+MY_PV=${PV/_p/-}
+MY_P=""
+SRC_URI="https://github.com/Mellanox/mstflint/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+IUSE="adb-generic-tools inband ssl"
+SLOT="0"
+RDEPEND="dev-db/sqlite:3=
+ sys-libs/zlib:=
+ inband? ( sys-fabric/libibmad )
+ adb-generic-tools? (
+ dev-libs/boost:=
+ dev-libs/expat:=
+ )
+ ssl? ( dev-libs/openssl:= )"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+ echo '#define TOOLS_GIT_SHA "'${EGIT_COMMIT}'"' > ./common/gitversion.h || die
+}
+
+src_configure() {
+ eautoreconf
+ econf $(use_enable inband) $(use_enable ssl openssl) $(use adb-generic-tools && printf -- '--enable-adb-generic-tools')
+}
+
+src_compile() {
+ if use adb-generic-tools; then
+ pushd ext_libs/json >/dev/null || die
+ emake
+ popd >/dev/null || die
+ fi
+ default
+}