summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-firmware/b43-firmware/b43-firmware-5.100.138.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-firmware/b43-firmware/b43-firmware-5.100.138.ebuild')
-rw-r--r--sys-firmware/b43-firmware/b43-firmware-5.100.138.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-firmware/b43-firmware/b43-firmware-5.100.138.ebuild b/sys-firmware/b43-firmware/b43-firmware-5.100.138.ebuild
new file mode 100644
index 000000000000..9e6ca17c5eb3
--- /dev/null
+++ b/sys-firmware/b43-firmware/b43-firmware-5.100.138.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+: ${B43_FIRMWARE_SRC_OBJ:=wl_apsta.o}
+
+MY_P="broadcom-wl-${PV}"
+DESCRIPTION="broadcom firmware for b43 LP PHY and >=linux-3.2"
+HOMEPAGE="http://linuxwireless.org/en/users/Drivers/b43"
+SRC_URI="http://www.lwfinger.com/b43-firmware/${MY_P}.tar.bz2"
+
+LICENSE="Broadcom"
+SLOT="b43"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RESTRICT="mirror binchecks strip"
+
+DEPEND=">=net-wireless/b43-fwcutter-015"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ mkdir ebuild-output
+ b43-fwcutter -w ebuild-output $(find -name ${B43_FIRMWARE_SRC_OBJ}) || die
+}
+
+src_install() {
+ insinto /lib/firmware
+ doins -r ebuild-output/* || die
+}