summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-27 00:50:46 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-27 00:50:46 +0100
commit3a467dfdc26d9fc7fadb12bb03ce016cc2e92e7a (patch)
tree6bd72bb3cf5684dcc8151896aec6ee15a9b9caaf /sys-firmware/ipw2100-firmware
parentsys-firmware/bluez-firmware: update EAPI 5 -> 8 (diff)
downloadgentoo-3a467dfdc26d9fc7fadb12bb03ce016cc2e92e7a.tar.gz
gentoo-3a467dfdc26d9fc7fadb12bb03ce016cc2e92e7a.tar.bz2
gentoo-3a467dfdc26d9fc7fadb12bb03ce016cc2e92e7a.zip
sys-firmware/ipw2100-firmware: update EAPI 5 -> 8
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-firmware/ipw2100-firmware')
-rw-r--r--sys-firmware/ipw2100-firmware/ipw2100-firmware-1.3-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sys-firmware/ipw2100-firmware/ipw2100-firmware-1.3-r1.ebuild b/sys-firmware/ipw2100-firmware/ipw2100-firmware-1.3-r1.ebuild
new file mode 100644
index 000000000000..319a34b61d7b
--- /dev/null
+++ b/sys-firmware/ipw2100-firmware/ipw2100-firmware-1.3-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P=${P/firmware/fw}
+
+DESCRIPTION="Firmware for the Intel PRO/Wireless 2100 3B miniPCI adapter"
+HOMEPAGE="http://ipw2100.sourceforge.net/"
+SRC_URI="mirror://gentoo/${MY_P}.tgz"
+
+LICENSE="ipw2100-fw"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+S=${WORKDIR}
+
+src_install() {
+ insinto /lib/firmware
+ doins ipw2100-${PV}{,-i,-p}.fw
+}