summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-firmware/ipxe/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-firmware/ipxe/files')
-rw-r--r--sys-firmware/ipxe/files/ipxe-1.0.0_p20130925-git-version.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-firmware/ipxe/files/ipxe-1.0.0_p20130925-git-version.patch b/sys-firmware/ipxe/files/ipxe-1.0.0_p20130925-git-version.patch
new file mode 100644
index 000000000000..a981abdd892e
--- /dev/null
+++ b/sys-firmware/ipxe/files/ipxe-1.0.0_p20130925-git-version.patch
@@ -0,0 +1,38 @@
+From 6153c09c41034250408f3596555fcaae715da46c Mon Sep 17 00:00:00 2001
+From: Florian Schmaus <flo@geekplace.eu>
+Date: Mon, 28 Jul 2014 16:47:48 +0100
+Subject: [PATCH] [build] Set GITVERSION only if there is a git repository
+
+The $(BIN)/version.%.o target will fail if iPXE is built within a
+non-git repository, e.g. when the user downloaded and extracted an
+archive containing iPXE sources, *and* if any parent directory of the
+iPXE sources is a git repository (or even contains a directory named
+".git"). This is because git will by default ascend the directory
+tree and look for ".git".
+
+The problem typically manifests on source based distributions, see for
+example https://bugs.gentoo.org/show_bug.cgi?id=482804
+
+Modified-by: Michael Brown <mcb30@ipxe.org>
+Signed-off-by: Michael Brown <mcb30@ipxe.org>
+---
+ src/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index 22a7335..c6760ee 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -190,8 +190,8 @@ VERSION_PATCH = 0
+ EXTRAVERSION = +
+ MM_VERSION = $(VERSION_MAJOR).$(VERSION_MINOR)
+ VERSION = $(MM_VERSION).$(VERSION_PATCH)$(EXTRAVERSION)
++ifneq ($(wildcard ../.git),)
+ GITVERSION := $(shell git describe --always --abbrev=1 --match "" 2>/dev/null)
+-ifneq ($(GITVERSION),)
+ VERSION += ($(GITVERSION))
+ endif
+ version :
+--
+2.3.2
+