summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-06-20 23:54:37 -0400
committerMike Frysinger <vapier@gentoo.org>2016-06-20 23:54:37 -0400
commit1c462a86b4f18a82fc84f352ca28801b3be7c919 (patch)
treec60b93f333daeb9625ebf742aefe53cdbc635ce4 /sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild
parentapp-emulation/qemu: drop kvm_stat to match upstream #586158 (diff)
downloadgentoo-1c462a86b4f18a82fc84f352ca28801b3be7c919.tar.gz
gentoo-1c462a86b4f18a82fc84f352ca28801b3be7c919.tar.bz2
gentoo-1c462a86b4f18a82fc84f352ca28801b3be7c919.zip
sys-firmware/ipxe: move header/toolchain setup to src_configure
Diffstat (limited to 'sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild')
-rw-r--r--sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild b/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild
index 631f90f14d45..7a57332ce739 100644
--- a/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild
+++ b/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild
@@ -30,7 +30,9 @@ S="${WORKDIR}/ipxe-${GIT_SHORT}/src"
src_prepare() {
epatch "${FILESDIR}"/${P}-git-version.patch #482804
+}
+src_configure() {
cat <<-EOF > "${S}"/config/local/general.h
#undef BANNER_TIMEOUT
#define BANNER_TIMEOUT 0
@@ -42,10 +44,11 @@ EOF
#define CONSOLE_VMWARE
EOF
fi
+
+ tc-ld-disable-gold
}
src_compile() {
- tc-ld-disable-gold
ipxemake() {
# Q='' makes the build verbose since that's what everyone loves now
emake Q='' \