summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-09-02 00:17:33 +0200
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-09-02 00:17:33 +0200
commit7b60c9549d42b016ba8c43ea63e6d25f46d6e7d3 (patch)
tree926e40a3e5b413b50dec45f6bc50f520f01785d5 /sys-firmware/radeon-ucode/radeon-ucode-20140823.ebuild
parentx11-plugins/purple-facebook: Version bump, containing significant bug fixes. ... (diff)
downloadgentoo-7b60c9549d42b016ba8c43ea63e6d25f46d6e7d3.tar.gz
gentoo-7b60c9549d42b016ba8c43ea63e6d25f46d6e7d3.tar.bz2
gentoo-7b60c9549d42b016ba8c43ea63e6d25f46d6e7d3.zip
x11-drivers/radeon-ucode: move to sys-firmware/radeon-ucode
Diffstat (limited to 'sys-firmware/radeon-ucode/radeon-ucode-20140823.ebuild')
-rw-r--r--sys-firmware/radeon-ucode/radeon-ucode-20140823.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-firmware/radeon-ucode/radeon-ucode-20140823.ebuild b/sys-firmware/radeon-ucode/radeon-ucode-20140823.ebuild
new file mode 100644
index 000000000000..56d2a4cb214e
--- /dev/null
+++ b/sys-firmware/radeon-ucode/radeon-ucode-20140823.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info
+
+DESCRIPTION="IRQ microcode for r6xx/r7xx/Evergreen/N.Islands/S.Islands Radeon GPUs and APUs"
+HOMEPAGE="http://people.freedesktop.org/~agd5f/radeon_ucode/"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="radeon-ucode"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="!sys-kernel/linux-firmware[-savedconfig]"
+
+S=${WORKDIR}/${PN/-/_}
+
+src_install() {
+ insinto /lib/firmware/radeon
+ FILES=( *.bin )
+ doins ${FILES[@]} || die "doins failed"
+}
+
+pkg_postinst() {
+ if linux_config_exists && linux_chkconfig_builtin DRM_RADEON; then
+ if ! linux_chkconfig_present FIRMWARE_IN_KERNEL || \
+ ! [[ "$(linux_chkconfig_string EXTRA_FIRMWARE)" == *_rlc.bin* ]]; then
+ ewarn "Your kernel has radeon DRM built-in but not the IRQ microcode."
+ ewarn "For kernel modesetting to work, please set in kernel config"
+ ewarn "CONFIG_FIRMWARE_IN_KERNEL=y"
+ ewarn "CONFIG_EXTRA_FIRMWARE_DIR=\"/lib/firmware\""
+ ewarn "CONFIG_EXTRA_FIRMWARE=\"${FILES[@]/#/radeon/}\""
+ ewarn "You may skip microcode files for which no hardware is installed."
+ ewarn "More information at https://wiki.gentoo.org/wiki/Radeon#Firmware"
+ fi
+ fi
+}