summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-08-29 20:27:14 -0400
committerMike Frysinger <vapier@gentoo.org>2015-08-29 20:27:14 -0400
commit0680193cd7aa2e3e7c1472d31739df157d90e4cb (patch)
treee8188c28c55b4d5a06d3632c827d8cb41d0dd69d /sys-firmware/seabios
parentsys-firmware/seabios: add qemu herd (diff)
downloadgentoo-0680193cd7aa2e3e7c1472d31739df157d90e4cb.tar.gz
gentoo-0680193cd7aa2e3e7c1472d31739df157d90e4cb.tar.bz2
gentoo-0680193cd7aa2e3e7c1472d31739df157d90e4cb.zip
sys-firmware/seabios: add USE=debug to control debug output levels
Diffstat (limited to 'sys-firmware/seabios')
-rw-r--r--sys-firmware/seabios/seabios-1.8.2.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/sys-firmware/seabios/seabios-1.8.2.ebuild b/sys-firmware/seabios/seabios-1.8.2.ebuild
index 61b1a8d77671..23e935b8e815 100644
--- a/sys-firmware/seabios/seabios-1.8.2.ebuild
+++ b/sys-firmware/seabios/seabios-1.8.2.ebuild
@@ -32,9 +32,10 @@ HOMEPAGE="http://www.seabios.org"
LICENSE="LGPL-3 GPL-3"
SLOT="0"
-IUSE="+binary +seavgabios"
+IUSE="+binary debug +seavgabios"
-REQUIRED_USE="ppc? ( binary )
+REQUIRED_USE="debug? ( !binary )
+ ppc? ( binary )
ppc64? ( binary )"
DEPEND="
@@ -73,7 +74,14 @@ src_prepare() {
}
src_configure() {
- use binary || tc-ld-disable-gold #438058
+ use binary && return
+
+ tc-ld-disable-gold #438058
+
+ if use debug ; then
+ echo "CONFIG_DEBUG_LEVEL=8" >.config
+ fi
+ _emake config
}
_emake() {