summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-02-11 15:15:07 -0600
committerMatthias Maier <tamiko@gentoo.org>2018-02-11 15:30:27 -0600
commit24e0876ca53199dcde6ee2e8384e9f9c6319edff (patch)
tree5963c65ed6f0d0bdb10c723dc0b8980e1b6a74bd /sys-firmware/seabios
parentapp-emulation/qemu-guest-agent: version bump to 2.11.0 (diff)
downloadgentoo-24e0876ca53199dcde6ee2e8384e9f9c6319edff.tar.gz
gentoo-24e0876ca53199dcde6ee2e8384e9f9c6319edff.tar.bz2
gentoo-24e0876ca53199dcde6ee2e8384e9f9c6319edff.zip
sys-firmware/seabios: version bump to 1.11.0
Bug: https://bugs.gentoo.org/617232 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-firmware/seabios')
-rw-r--r--sys-firmware/seabios/Manifest2
-rw-r--r--sys-firmware/seabios/seabios-1.11.0.ebuild137
2 files changed, 139 insertions, 0 deletions
diff --git a/sys-firmware/seabios/Manifest b/sys-firmware/seabios/Manifest
index c849ca267405..2b99e80927e3 100644
--- a/sys-firmware/seabios/Manifest
+++ b/sys-firmware/seabios/Manifest
@@ -2,4 +2,6 @@ DIST bios.bin-1.10.1.xz 63668 BLAKE2B 82b055acc851305a2f9d54419da846a3ed1924038c
DIST seabios-1.10.1.tar.gz 588092 BLAKE2B d27d16e5d02e00695dd8790ef63bc5d99815580d6d6d5bcbbb70b36a9cc7984cca6d1c4c274a20a992e11460b52583ec9e77f8e2b22066349f2915cbf6fb9e2f SHA512 b2f1c2b15853b1cc949f741ae13f32fd133efb0d0917e1cdfb253f9cd0bc9bb0b42c592cdd87bc74ccbb12a4301c102ae723ccdb490ea4716e0c9dca3dd3fead
DIST seabios-1.10.2-bin.tar.xz 121172 BLAKE2B 9d4ff624b638773e59bbf6674fb8630bd815d75af1a81db4de7f9740c37485330e6d054448f2301a97455ff0d3190d988ce0348eac78bd978982b6ce5146e4f6 SHA512 a46ce389b8b0fe7182a3dc2954fab7e0ef27ac65823e3785c247ccf77c37eaa746d94f74a4a29a221aa16ab508cf07ec8d399aa612d5c0184b48bce24c663b69
DIST seabios-1.10.2.tar.gz 589283 BLAKE2B 08fdbecf7fb06629db472adb05a780249dbf0e0a44d04dcced5480d631c133f74ecd04b04486db3bb817b8e119e783c4b09c3ade15b9a6cc956537e9f7204514 SHA512 ea8396fe247a3bd16b43ab775cf8e23f139673b94e83f450cadb094cc8117ca7e9ef518162d965209d5ab091c96f70ec5cc8ec8d15b638e06c4c8f7a0e1609dc
+DIST seabios-1.11.0-bin.tar.xz 158552 BLAKE2B 44c42b9eea70a090ad51296949fe79e5360b569bae791fe84f447061f8dbcdb6b601501e2cc1607b62308f3118087386d15ba32c8495202f62f9f9a1e3cf27c3 SHA512 03a1523dc99dbf6e353e7844a4f12020d88bf8d5cbfd187007663ab1b02447b02694f27ee93aa46a18a5ab161f13b1ffe62f2d0f678cd86975a3d53295a6eb1e
+DIST seabios-1.11.0.tar.gz 607746 BLAKE2B 9f688be6b8f7c0fcbd72b59ac649a9c763fdd9e2971a4d85636c9972efc0ad42082a1622a8c41156ad1e2063907349c2e02cff9aeb444844dc445b5f7d6062bb SHA512 cae79c720bfbba3321777bbc6d5bde432fe56e2ba8f1be8acfebbde0bd453a58e889f5fa24db6055dca0a3a56d35b907761723ea35ef248c5f812129d0a27b77
DIST seavgabios-bin-1.10.1.tar.xz 20408 BLAKE2B e8678a5e1b7cf5c36017c3f3dec1996103304394215ce52e9fc23bb0581d253a87be0592eb5b2f1ef7bbfb03e80cd937d82b04a46c76e41fa5b95063782075b2 SHA512 7fe97efaf61c2d1e72c8df27b5108c80f6a51f5a7370de68720b0f71abe05ae5765dd867d127df2fa6182b5d4702a9ef7549e7170fec5071b31a6066db20c219
diff --git a/sys-firmware/seabios/seabios-1.11.0.ebuild b/sys-firmware/seabios/seabios-1.11.0.ebuild
new file mode 100644
index 000000000000..699fca3bfa7a
--- /dev/null
+++ b/sys-firmware/seabios/seabios-1.11.0.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit eutils toolchain-funcs python-any-r1
+
+# SeaBIOS maintainers sometimes don't release stable tarballs or stable
+# binaries to generate the stable tarball the following is necessary:
+# git clone git://git.seabios.org/seabios.git && cd seabios
+# git archive --output seabios-${PV}.tar.gz --prefix seabios-${PV}/ rel-${PV}
+
+if [[ ${PV} == *9999* || -n "${EGIT_COMMIT}" ]] ; then
+ EGIT_REPO_URI="git://git.seabios.org/seabios.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+ # Binary versions taken from fedora:
+ # http://download.fedoraproject.org/pub/fedora/linux/development/rawhide/Everything/x86_64/os/Packages/s/
+ # seabios-bin-1.10.2-1.fc27.noarch.rpm
+ # seavgabios-bin-1.10.2-1.fc27.noarch.rpm
+ SRC_URI="
+ !binary? ( https://code.coreboot.org/p/seabios/downloads/get/${P}.tar.gz )
+ binary? ( https://dev.gentoo.org/~tamiko/distfiles/${P}-bin.tar.xz )"
+fi
+
+DESCRIPTION="Open Source implementation of a 16-bit x86 BIOS"
+HOMEPAGE="https://www.seabios.org/"
+
+LICENSE="LGPL-3 GPL-3"
+SLOT="0"
+IUSE="+binary debug +seavgabios"
+
+REQUIRED_USE="debug? ( !binary )
+ !amd64? ( !x86? ( binary ) )"
+
+# The amd64/x86 check is needed to workaround #570892.
+SOURCE_DEPEND="
+ >=sys-power/iasl-20060912
+ ${PYTHON_DEPS}"
+DEPEND="
+ !binary? (
+ amd64? ( ${SOURCE_DEPEND} )
+ x86? ( ${SOURCE_DEPEND} )
+ )"
+RDEPEND=""
+
+pkg_pretend() {
+ if ! use binary; then
+ ewarn "You have decided to compile your own SeaBIOS. This is not"
+ ewarn "supported by upstream unless you use their recommended"
+ ewarn "toolchain (which you are not)."
+ elog
+ ewarn "If you are intending to use this build with QEMU, realize"
+ ewarn "you will not receive any support if you have compiled your"
+ ewarn "own SeaBIOS. Virtual machines subtly fail based on changes"
+ ewarn "in SeaBIOS."
+ fi
+}
+
+pkg_setup() {
+ use binary || python-any-r1_pkg_setup
+}
+
+src_unpack() {
+ default
+
+ # This simplifies the logic between binary & source builds.
+ mkdir -p "${S}"
+}
+
+src_configure() {
+ use binary && return
+
+ tc-ld-disable-gold #438058
+
+ if use debug ; then
+ echo "CONFIG_DEBUG_LEVEL=8" >.config
+ fi
+ _emake config
+}
+
+_emake() {
+ LANG=C \
+ emake V=1 \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getLD)" \
+ AR="$(tc-getAR)" \
+ OBJCOPY="$(tc-getOBJCOPY)" \
+ RANLIB="$(tc-getRANLIB)" \
+ OBJDUMP="$(tc-getOBJDUMP)" \
+ HOST_CC="$(tc-getBUILD_CC)" \
+ VERSION="Gentoo/${EGIT_COMMIT:-${PVR}}" \
+ "$@"
+}
+
+src_compile() {
+ use binary && return
+
+ cp "${FILESDIR}/seabios/config.seabios-256k" .config || die
+ _emake oldnoconfig
+ _emake out/bios.bin
+ mv out/bios.bin ../bios-256k.bin || die
+
+ if use seavgabios ; then
+ local config t targets=(
+ cirrus
+ isavga
+ qxl
+ stdvga
+ virtio
+ vmware
+ )
+ for t in "${targets[@]}" ; do
+ emake clean distclean
+ cp "${FILESDIR}/seavgabios/config.vga-${t}" .config || die
+ _emake oldnoconfig
+ _emake out/vgabios.bin
+ cp out/vgabios.bin ../vgabios-${t}.bin || die
+ done
+ fi
+}
+
+src_install() {
+
+ insinto /usr/share/seabios
+ use binary && doins ../bios.bin
+ doins ../bios-256k.bin
+
+ if use seavgabios ; then
+ insinto /usr/share/seavgabios
+ doins ../vgabios*.bin
+ fi
+}