summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-11-10 17:11:52 +0100
committerPacho Ramos <pacho@gentoo.org>2023-11-10 17:19:33 +0100
commit3e5e36efd6ec8d32eb5d7bb1dbce1adf2c54176b (patch)
treea2a50007181c6fed978a70ea1fcc6ebc6317f1fa /sys-firmware
parentx11-themes/papirus-icon-theme: drop 20230801 (diff)
downloadgentoo-3e5e36efd6ec8d32eb5d7bb1dbce1adf2c54176b.tar.gz
gentoo-3e5e36efd6ec8d32eb5d7bb1dbce1adf2c54176b.tar.bz2
gentoo-3e5e36efd6ec8d32eb5d7bb1dbce1adf2c54176b.zip
sys-firmware/sof-firmware: add 2023.09.1
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/sof-firmware/Manifest1
-rw-r--r--sys-firmware/sof-firmware/sof-firmware-2023.09.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-firmware/sof-firmware/Manifest b/sys-firmware/sof-firmware/Manifest
index 010e2d21c688..2b7f280d6f36 100644
--- a/sys-firmware/sof-firmware/Manifest
+++ b/sys-firmware/sof-firmware/Manifest
@@ -1,2 +1,3 @@
DIST sof-firmware-2.2.6.tar.gz 4394096 BLAKE2B 8fa0fb97cfdaa13b30f34f46789bbb1700f4a3be994f11a55226bf617c9ade7ccde931eeb2f263448e355e82f281bbb70c66624a71645062cdfb68bd81a9d3a1 SHA512 33a836fdc9006aead24e14c15703040164b0878d48c6dd32f0a6ae558c99a43c768eb793e308550fd32dfb0e0f93783cff6c42f2618557ebac2a057425115e9e
+DIST sof-firmware-2023.09.1.tar.gz 5451137 BLAKE2B 8f52d5855cc58cd03fc9a1c0afa69e00ebbd7ff43a7d02401253cf8340d2722c9cb4e5f96d4d4c593fe160d48d5046bed4f4dc8c7813696b8128c65138365cd8 SHA512 74a0de0cfc561a273f2f535239a5e23a3bdd7718c1f70e320cf11b58ff499ff437f98aab3171901165d3da4156b4374f5e4259bee152f7d10755b69e98b8ba51
DIST sof-firmware-2023.09.tar.gz 5451579 BLAKE2B 7535559c6833bd19c15c1f6e6bd88ee5c13ed79f93e0772cdc9df335cf4e89938969bd9babdf8c6cc1321af27e6704477f3a3db3c46295879216fd43358cf5b4 SHA512 7ef81549c76164629400622fa1b512b6061a37b9ba14383d69ac10b2e7dc35c4f35bd6444b15e725c749c23564ec84646960fedcd776b5c2ec11bda3933a633d
diff --git a/sys-firmware/sof-firmware/sof-firmware-2023.09.1.ebuild b/sys-firmware/sof-firmware/sof-firmware-2023.09.1.ebuild
new file mode 100644
index 000000000000..ec08a9cf1a8f
--- /dev/null
+++ b/sys-firmware/sof-firmware/sof-firmware-2023.09.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Sound Open Firmware (SOF) binary files"
+HOMEPAGE="https://www.sofproject.org https://github.com/thesofproject/sof https://github.com/thesofproject/sof-bin"
+SRC_URI="https://github.com/thesofproject/sof-bin/releases/download/v${PV}/sof-bin-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/sof-bin-${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Needed for sof-ctl
+RDEPEND="media-libs/alsa-lib"
+
+QA_PREBUILT="usr/bin/sof-ctl
+ usr/bin/sof-logger
+ usr/bin/sof-probes"
+
+src_install() {
+ dodir /lib/firmware/intel
+ dodir /usr/bin
+ FW_DEST="${D}/lib/firmware/intel" TOOLS_DEST="${D}/usr/bin" "${S}/install.sh" || die
+}
+
+pkg_preinst() {
+ local sofpath="${EROOT}/lib/firmware/intel/sof"
+ if [[ ! -L "${sofpath}" && -d "${sofpath}" ]] ; then
+ rm -r "${sofpath}" || die
+ fi
+}