summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2021-04-24 18:50:52 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-24 18:50:52 +0200
commit711402a4ea66b1d5a2edc0624eddfa7d2afed881 (patch)
tree2f40fde7262908c7a394afdbdc51688fdb7a29fe /sys-firmware
parentsys-firmware/ipxe: [QA] Add missing || die and canonical ordering (diff)
downloadgentoo-711402a4ea66b1d5a2edc0624eddfa7d2afed881.tar.gz
gentoo-711402a4ea66b1d5a2edc0624eddfa7d2afed881.tar.bz2
gentoo-711402a4ea66b1d5a2edc0624eddfa7d2afed881.zip
sys-firmware/sgabios: EAPI 7
Closes: https://bugs.gentoo.org/784134 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/sgabios/sgabios-0.1_pre10.ebuild14
1 files changed, 2 insertions, 12 deletions
diff --git a/sys-firmware/sgabios/sgabios-0.1_pre10.ebuild b/sys-firmware/sgabios/sgabios-0.1_pre10.ebuild
index 1f4e844ac430..150fd1ef8bec 100644
--- a/sys-firmware/sgabios/sgabios-0.1_pre10.ebuild
+++ b/sys-firmware/sgabios/sgabios-0.1_pre10.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit toolchain-funcs
@@ -12,24 +12,14 @@ HOMEPAGE="https://code.google.com/p/sgabios/"
SRC_URI="mirror://gentoo/${P}.tar.gz
!binary? ( https://dev.gentoo.org/~tamiko/distfiles/${P}.tar.gz )
binary? ( https://dev.gentoo.org/~tamiko/distfiles/${P}-bin.tar.xz )"
+S="${WORKDIR}/sgabios-a85446a"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE="+binary"
-
REQUIRED_USE="!amd64? ( !x86? ( binary ) )"
-S="${WORKDIR}/sgabios-a85446a"
-
-src_prepare() {
- if use binary; then
- eapply_user
- return
- fi
- default
-}
-
src_compile() {
use binary && return