summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-12-31 11:43:27 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-01-13 21:45:50 +0100
commitb70db01c51e24eeb440f36e00fda70ffd85d1ae1 (patch)
treee4b7e5e3770dbf795e75501a580de699ea7e75c5 /sys-firmware
parentnet-misc/ndppd: EAPI8 bump, minor improvements (diff)
downloadgentoo-b70db01c51e24eeb440f36e00fda70ffd85d1ae1.tar.gz
gentoo-b70db01c51e24eeb440f36e00fda70ffd85d1ae1.tar.bz2
gentoo-b70db01c51e24eeb440f36e00fda70ffd85d1ae1.zip
sys-firmware/vgabios: EAPI8, fix LICENSE, fix calling gcc directly
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://bugs.gentoo.org/721592 Closes: https://github.com/gentoo/gentoo/pull/34574 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/vgabios/vgabios-0.8a-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-firmware/vgabios/vgabios-0.8a-r1.ebuild b/sys-firmware/vgabios/vgabios-0.8a-r1.ebuild
new file mode 100644
index 000000000000..ed39a5dd8bb1
--- /dev/null
+++ b/sys-firmware/vgabios/vgabios-0.8a-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="VGA BIOS implementation"
+HOMEPAGE="https://www.nongnu.org/vgabios/"
+SRC_URI="https://savannah.gnu.org/download/${PN}/${P}.tgz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="binary debug"
+BDEPEND="!binary? ( sys-devel/dev86 )"
+
+src_compile() {
+ if ! use binary ; then
+ emake clean # Necessary to clean up the pre-built pieces
+ emake biossums CC="$(tc-getCC)"
+ emake GCC="$(tc-getCC)" CC="$(tc-getCC)"
+ fi
+}
+
+src_install() {
+ insinto /usr/share/vgabios
+
+ # Stock VGABIOS
+ newins VGABIOS-lgpl-latest.bin vgabios.bin
+ use debug && newins VGABIOS-lgpl-latest.debug.bin vgabios.debug.bin
+
+ # Cirrus
+ newins VGABIOS-lgpl-latest.cirrus.bin vgabios-cirrus.bin
+ use debug && newins VGABIOS-lgpl-latest.cirrus.debug.bin \
+ vgabios-cirrus.debug.bin
+
+ # Banshee
+ newins VGABIOS-lgpl-latest.banshee.bin vgabios-banshee.bin
+
+}