summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-01-07 18:44:49 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-01-07 19:39:44 +0000
commit11ad885f29c27e5b251715f892e3b2bd77cfc768 (patch)
tree77aa8ffee325a2cc35cab213e334d0023ee64554 /sys-freebsd
parentsys-libs/glibc: Migrate CROSSCOMPILE_OPTS=headers-only -> USE=headers-only (diff)
downloadgentoo-11ad885f29c27e5b251715f892e3b2bd77cfc768.tar.gz
gentoo-11ad885f29c27e5b251715f892e3b2bd77cfc768.tar.bz2
gentoo-11ad885f29c27e5b251715f892e3b2bd77cfc768.zip
sys-freebsd/freebsd-lib: Migrate CROSSCOMPILE_OPTS=headers-only -> USE=headers-only
CROSSCOMPILE_OPTS is a USE_EXPAND of a single item: headers-only. Convert it to a global USE flag instead. Mechanical ebuild rename done as: $ sed -e 's@crosscompile_opts_headers-only@headers-only@g' \ -i $(git grep -l headers-only) 'headers-only' flag is used by crossdev to bootstrap stage1 compiler before libc is available. crossdev switched to USE=headers-only in =sys-devel/crossdev-20171230. Bug: https://bugs.gentoo.org/642712 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-11.1.ebuild8
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-8.2-r1.ebuild8
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-9.1-r11.ebuild8
3 files changed, 12 insertions, 12 deletions
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-11.1.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-11.1.ebuild
index a1e2b461df4b..db383d629470 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-11.1.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-11.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -72,7 +72,7 @@ if [ "${CTARGET}" = "${CHOST}" -a "${CATEGORY#*cross-}" != "${CATEGORY}" ]; then
fi
IUSE="atm bluetooth ssl hesiod ipv6 kerberos usb netware
- build crosscompile_opts_headers-only zfs pam xinetd
+ build headers-only zfs pam xinetd
userland_GNU userland_BSD"
QA_DT_NEEDED="lib/libc.so.7 usr/lib32/libc.so.7"
@@ -416,7 +416,7 @@ src_compile() {
cd "${WORKDIR}/include"
$(freebsd_get_bmake) CC="$(tc-getCC)" SRCTOP="${WORKDIR}" || die "make include failed"
- use crosscompile_opts_headers-only && return 0
+ use headers-only && return 0
# Bug #270098
append-flags $(test-flags -fno-strict-aliasing)
@@ -547,7 +547,7 @@ do_install() {
CTARGET="${CHOST}" \
install_includes ${INCLUDEDIR}
- is_crosscompile && use crosscompile_opts_headers-only && return 0
+ is_crosscompile && use headers-only && return 0
# Install a libusb.pc for better compat with Linux's libusb
if use usb ; then
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-8.2-r1.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-8.2-r1.ebuild
index 755c53b84971..8af19aedf5f0 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-8.2-r1.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-8.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=2
@@ -51,7 +51,7 @@ if [ "${CTARGET}" = "${CHOST}" -a "${CATEGORY#*cross-}" != "${CATEGORY}" ]; then
fi
IUSE="atm bluetooth ssl hesiod ipv6 kerberos usb netware
- build bootstrap crosscompile_opts_headers-only"
+ build bootstrap headers-only"
pkg_setup() {
[ -c /dev/zero ] || \
@@ -193,7 +193,7 @@ src_compile() {
cd "${WORKDIR}/include"
$(freebsd_get_bmake) CC="$(tc-getCC)" || die "make include failed"
- use crosscompile_opts_headers-only && return 0
+ use headers-only && return 0
# Bug #270098
append-flags $(test-flags -fno-strict-aliasing)
@@ -275,7 +275,7 @@ src_install() {
doins "${S}/msun/src/math.h"
fi
- use crosscompile_opts_headers-only && return 0
+ use headers-only && return 0
local mylibdir=$(get_libdir)
if [ "${CTARGET}" != "${CHOST}" ]; then
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r11.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r11.ebuild
index 8eee4f7d190c..92881fadfbc3 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r11.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -54,7 +54,7 @@ if [ "${CTARGET}" = "${CHOST}" -a "${CATEGORY#*cross-}" != "${CATEGORY}" ]; then
fi
IUSE="atm bluetooth ssl hesiod ipv6 kerberos usb netware
- build crosscompile_opts_headers-only zfs
+ build headers-only zfs
userland_GNU userland_BSD"
QA_DT_NEEDED="lib/libc.so.7 usr/lib32/libc.so.7"
@@ -358,7 +358,7 @@ src_compile() {
cd "${WORKDIR}/include"
$(freebsd_get_bmake) CC="$(tc-getCC)" || die "make include failed"
- use crosscompile_opts_headers-only && return 0
+ use headers-only && return 0
# Bug #270098
append-flags $(test-flags -fno-strict-aliasing)
@@ -485,7 +485,7 @@ do_install() {
CTARGET="${CHOST}" \
install_includes ${INCLUDEDIR}
- is_crosscompile && use crosscompile_opts_headers-only && return 0
+ is_crosscompile && use headers-only && return 0
for i in $(get_subdirs) ; do
einfo "Installing in ${i}..."