summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-26 15:35:03 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-26 16:31:28 -0400
commitaa36894b8102eaa0ec5c7ae219cb614176bc5c58 (patch)
tree555eeea68d4e69d8707431d0a982d08a3344debc /sys-freebsd
parentsys-freebsd/freebsd-bin: drop EAPI=2 (diff)
downloadgentoo-aa36894b8102eaa0ec5c7ae219cb614176bc5c58.tar.gz
gentoo-aa36894b8102eaa0ec5c7ae219cb614176bc5c58.tar.bz2
gentoo-aa36894b8102eaa0ec5c7ae219cb614176bc5c58.zip
sys-freebsd/boot0: drop EAPI=2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/boot0/Manifest3
-rw-r--r--sys-freebsd/boot0/boot0-9.1.ebuild63
-rw-r--r--sys-freebsd/boot0/files/boot0-9.2-gcc46.patch66
3 files changed, 0 insertions, 132 deletions
diff --git a/sys-freebsd/boot0/Manifest b/sys-freebsd/boot0/Manifest
index d3666577ec1a..f3dcd89d595d 100644
--- a/sys-freebsd/boot0/Manifest
+++ b/sys-freebsd/boot0/Manifest
@@ -1,4 +1 @@
-DIST freebsd-contrib-9.1.tar.bz2 54751432 BLAKE2B 8a30e78021e6388d679637d2dbe0ed3f4896d3902064baaafa79de9c328171cbcb895b0ffd3d0d0cd3ca25c93a73584ed4900b45bd672a73b15b75721de59de5 SHA512 71be13049258c6e6b5e4f63cc16da5d349a89d68f04d87446e4ad33ae8bf2a93ea67d9c256b7bec60b61e65db0487268070cfb77a484c3ac0f8ba368b48c2438
-DIST freebsd-lib-9.1.tar.bz2 3206685 BLAKE2B 67f93b7951fc03e877ee525d53b81ba49c8c1a70041c30aac97665d5dab7b3f2817fdb3bbb1475be66c33a7f996309e9020f1a3d1154fab8e2f6789f5ae0bb18 SHA512 40d0c36b6b889c404fa0e0afa38ba4e84a55bc88ffa2f98a70afbd7a32c4f32c158617ba770567d082a986d62c09b3ec8db3dc5ab853ee1c9bbe0b90bb82396e
DIST freebsd-src-11.1.tar.xz 147661560 BLAKE2B a9e6ba9d0e12c8b56ac58575d5f02931edbb6a3545d9dccae78810d2d0470a29b29dd7f724b03b8afafbca23717a71346e4cfbd3530e0f40118a23609c3f414e SHA512 b97707ec7a601ca6bcb682c45f6d94a38484301ac24630d7285eff6f88b027ce6900c93fc62f8ce36e0cf32c91f73a9d1c999db397b7f8782fd74a8551a03aca
-DIST freebsd-sys-9.1.tar.bz2 32588103 BLAKE2B 7f94a4735c6a17b39a86fa0fda0682924b18e4b466dc6319a5df889522aaeaffaa87e1b76582c48ae034df8c20169c8cea93bbd3d6e7abd0526716686f88dfe8 SHA512 7dc9d9e00dde8f592bb171f4386d02b655b73cb4f153fe5ec063d010a148ef0639eae0dcdb3eeb09ecd1e3653c69e49a2d261329fa6d0381d2ddabe258ddde6d
diff --git a/sys-freebsd/boot0/boot0-9.1.ebuild b/sys-freebsd/boot0/boot0-9.1.ebuild
deleted file mode 100644
index 54793cef68a1..000000000000
--- a/sys-freebsd/boot0/boot0-9.1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=2
-
-inherit bsdmk freebsd flag-o-matic
-
-DESCRIPTION="FreeBSD's bootloader"
-SLOT="0"
-KEYWORDS="~amd64-fbsd ~x86-fbsd"
-
-IUSE="bzip2 ieee1394 tftp zfs"
-
-SRC_URI="mirror://gentoo/${SYS}.tar.bz2
- mirror://gentoo/${LIB}.tar.bz2
- mirror://gentoo/${CONTRIB}.tar.bz2"
-
-RDEPEND=""
-DEPEND="=sys-freebsd/freebsd-mk-defs-${RV}*
- =sys-freebsd/freebsd-lib-${RV}*"
-
-S="${WORKDIR}/sys/boot"
-
-PATCHES=( "${FILESDIR}/${PN}-9.2-gcc46.patch"
- "${FILESDIR}/${PN}-add-nossp-cflags.patch" )
-
-boot0_use_enable() {
- use ${1} && mymakeopts="${mymakeopts} LOADER_${2}_SUPPORT=\"yes\""
-}
-
-pkg_setup() {
- boot0_use_enable ieee1394 FIREWIRE
- boot0_use_enable zfs ZFS
- boot0_use_enable tftp TFTP
- boot0_use_enable bzip2 BZIP2
-}
-
-src_prepare() {
- sed -e '/-fomit-frame-pointer/d' -e '/-mno-align-long-strings/d' \
- -i "${S}"/i386/boot2/Makefile \
- -i "${S}"/i386/gptboot/Makefile \
- -i "${S}"/i386/gptzfsboot/Makefile \
- -i "${S}"/i386/zfsboot/Makefile || die
-}
-
-src_compile() {
- strip-flags
- append-flags "-fno-strict-aliasing"
-
- cd "${WORKDIR}/lib/libstand" || die
- freebsd_src_compile
-
- cd "${S}"
- CFLAGS="${CFLAGS} -I${WORKDIR}/lib/libstand"
- LDFLAGS="${LDFLAGS} -L${WORKDIR}/lib/libstand"
- export LIBSTAND="${WORKDIR}/lib/libstand/libstand.a"
- NOFLAGSTRIP="yes" freebsd_src_compile
-}
-
-src_install() {
- dodir /boot/defaults
- mkinstall FILESDIR=/boot || die "mkinstall failed"
-}
diff --git a/sys-freebsd/boot0/files/boot0-9.2-gcc46.patch b/sys-freebsd/boot0/files/boot0-9.2-gcc46.patch
deleted file mode 100644
index ffd9f4351d1f..000000000000
--- a/sys-freebsd/boot0/files/boot0-9.2-gcc46.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-diff --git a/sys/boot/i386/Makefile.inc b/sys/boot/i386/Makefile.inc
-index f5faec7..a9cf593 100644
---- a/sys/boot/i386/Makefile.inc
-+++ b/sys/boot/i386/Makefile.inc
-@@ -12,7 +12,6 @@ LDFLAGS+= -nostdlib
- .if ${MACHINE_CPUARCH} == "amd64"
- CFLAGS+= -m32
- ACFLAGS+= -m32
--LDFLAGS+= -m elf_i386_fbsd
- AFLAGS+= --32
- .endif
-
-diff --git a/sys/boot/i386/boot2/Makefile b/sys/boot/i386/boot2/Makefile
-index 65815a5..61840dd 100644
---- a/sys/boot/i386/boot2/Makefile
-+++ b/sys/boot/i386/boot2/Makefile
-@@ -109,3 +109,10 @@ machine:
- # XXX: clang integrated-as doesn't grok .codeNN directives yet
- CFLAGS.boot1.S= ${CLANG_NO_IAS}
- CFLAGS+= ${CFLAGS.${.IMPSRC:T}}
-+
-+# gcc 4.6 or later version, -fno-asynchronous-unwind-tables is required to build.
-+CFLAGS+= -fno-asynchronous-unwind-tables
-+
-+.if ${MACHINE_CPUARCH} == "amd64"
-+LDFLAGS+= -m elf_i386_fbsd
-+.endif
-diff --git a/sys/boot/i386/gptboot/Makefile b/sys/boot/i386/gptboot/Makefile
-index e1a640a..29886cc 100644
---- a/sys/boot/i386/gptboot/Makefile
-+++ b/sys/boot/i386/gptboot/Makefile
-@@ -78,3 +78,8 @@ machine:
- # XXX: clang integrated-as doesn't grok .codeNN directives yet
- CFLAGS.gptldr.S= ${CLANG_NO_IAS}
- CFLAGS+= ${CFLAGS.${.IMPSRC:T}}
-+
-+.if ${MACHINE_CPUARCH} == "amd64"
-+LDFLAGS+= -m elf_i386_fbsd
-+.endif
-+
-diff --git a/sys/boot/i386/gptzfsboot/Makefile b/sys/boot/i386/gptzfsboot/Makefile
-index a2b8fcc..107f531 100644
---- a/sys/boot/i386/gptzfsboot/Makefile
-+++ b/sys/boot/i386/gptzfsboot/Makefile
-@@ -76,3 +76,8 @@ machine:
- # XXX: clang integrated-as doesn't grok .codeNN directives yet
- CFLAGS.gptldr.S= ${CLANG_NO_IAS}
- CFLAGS+= ${CFLAGS.${.IMPSRC:T}}
-+
-+.if ${MACHINE_CPUARCH} == "amd64"
-+LDFLAGS+= -m elf_i386_fbsd
-+.endif
-+
-diff --git a/sys/boot/i386/zfsboot/Makefile b/sys/boot/i386/zfsboot/Makefile
-index b2db778..252dc62 100644
---- a/sys/boot/i386/zfsboot/Makefile
-+++ b/sys/boot/i386/zfsboot/Makefile
-@@ -89,3 +89,8 @@ machine:
- # XXX: clang integrated-as doesn't grok .codeNN directives yet
- CFLAGS.zfsldr.S= ${CLANG_NO_IAS}
- CFLAGS+= ${CFLAGS.${.IMPSRC:T}}
-+
-+.if ${MACHINE_CPUARCH} == "amd64"
-+LDFLAGS+= -m elf_i386_fbsd
-+.endif
-+